Bug Issue: HTML5 doesn't load on IE and other bugs


Pages: 1

havana24

  • Subscriber - Stencyl Studio
  • *
October 07, 2019, 05:23:03 am
Hi there,

Here is a list of some html5 bugs and errors (Tested on build 10441):

1. On Internet Explorer (only on IE, on other browsers like Edge, Chrome, firefox etc. it works) the game doesn't load. It get stuck on the loading bar with an error like: "__loadWithProgress' is not defined.

2. There is a second loading bar before the classic loading bar that you can stylize. I've tried to make a gif and you can see a double loading bar:

3. Minor bug: when you test a game in html5 the favicon seems to be from the last game you published (or tested, I don't know).

I've attached the test game, but regarding all the bug listed you can just test any games and you'll get the same errors.

Thanks in advance,
Alessandro


New attachment added by havana24 - October 07, 2019, 05:23:28 am


Justin

  • Master Stencyler
  • *
November 01, 2019, 01:53:59 am
I've fixed issue number one in b10448.

Number 2 is actually on purpose. It can take a while for the game's main js script to load, and during this time, there won't be any indication of loading. This is more important for people with slow internet connections, or for larger games. It's not ideal that it conflicts visually so much with the resource-loading bar, but I'm not sure yet what to do about this.

I've split number 2 and 3 into their own issues so I can mark the more major issue, number 1, as resolved.
  • Issue Assigned from (none) to Justin
  • Status changed from New to Resolved


Pages: 1

Details

  • Reported
    October 07, 2019, 05:23:03 am
  • Updated
    November 01, 2019, 01:53:59 am

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    (none)
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Compiling/Testing Games

Tags


Attachments

* TestLoaderHTML5.stencyl (415.26 kB - downloaded 10 times.)