Bug Issue: flash player


Pages: 1

Casispanda

  • Junior Stencyler
November 08, 2019, 12:49:36 am
I downloaded a project on the stencly site, my teacher said that i had to test it before we could start. I kept gettting an error: [lime.utils.Assets] ERROR: There is no IMAGE asset with an ID of "assets/graphics/3x/tileset-31.png"
   at lime.utils::Log$/error()
   at lime.utils::Assets$/getAsset()
   at lime.utils::Assets$/getImage()
   at openfl.utils::Assets$/getBitmapData()
   at com.stencyl.utils::Assets$/getBitmapData()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\utils\Assets.hx:28]
   at com.stencyl.models.scene::Tileset/loadGraphics()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\models\scene\Tileset.hx:138]
   at com.stencyl.io::TilesetReader/read()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\io\TilesetReader.hx:49]
   at com.stencyl::Data/readResource()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Data.hx:272]
   at com.stencyl::Data/loadResourceFromMbs()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Data.hx:216]
   at com.stencyl.utils::LazyIntMap/get()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\utils\LazyIntMap.hx:51]
   at com.stencyl.models::Scene/readRawLayer()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\models\Scene.hx:553]
   at com.stencyl.models::Scene/readRawLayers()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\models\Scene.hx:510]
   at com.stencyl.models::Scene/load()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\models\Scene.hx:143]
   at com.stencyl::Engine/loadScene()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Engine.hx:996]
   at com.stencyl::Engine/begin()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Engine.hx:944]
   at com.stencyl::Engine()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Engine.hx:733]
   at Universal/preloaderComplete()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\Universal.hx:408]
   at lime.app::_Event_Void_Void/dispatch()
   at scripts::StencylPreloader/unload()[C:\Users\cashe\AppData\Roaming\Stencyl\stencylworks\games-generated\project3\Source\scripts\StencylPreloader.hx:340]
   at scripts::StencylPreloader/onLoaded()[C:\Users\cashe\AppData\Roaming\Stencyl\stencylworks\games-generated\project3\Source\scripts\StencylPreloader.hx:309]
   at lime.app::_Event_Void_Void/dispatch()
   at lime.utils::Preloader/start()
   at lime.utils::Preloader/updateProgress()
   at lime.utils::Preloader/current_onEnter()

i tried to Reinstall the app and deleted the project do download it aigan. What can i do to fix it??
Thanks for reaction!


Luyren

  • Master Stencyler
  • *
November 08, 2019, 09:40:04 am
Create a png called "tileset-31.png"

Go to Tools > Workspace >View Folder for this Game

Navigate to assets/graphics/3x

Place the png you created there and test your game.

Alternatively, go to Settings > Settings > Advanced, uncheck all Project Scales except x1. Then go to Tools > Game > Clean Up Unused Files and Clean Project, hit both of them. Close, reopen your game and test.

And if that doesn't work, check all the project scales and repeat the process.

If any of those work, please confirm which method fixed it for you, if any.


Justin

  • Master Stencyler
  • *
November 14, 2019, 07:59:41 pm
Luyren's second method should fix the issue.

This has already been fixed in the private builds, so I'll close this.
  • Status changed from New to Closed


Pages: 1

Details

  • Reported
    November 08, 2019, 12:49:36 am
  • Updated
    November 14, 2019, 07:59:41 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Closed
  • Priority
    Normal
  • Version
    Stencyl 3.4
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Compiling/Testing Games

Tags