Suggestion Issue: Make actor-layer operation function names more clear


Pages: 1

irock

  • Master Stencyler
  • *
February 13, 2020, 09:57:36 pm
The distinctions between, as an example, sendToBack() and moveToBottom(), are unclear based on the names.

Furthermore, multiple unhelpful terminologies with unclear differences are used, such as {"front" and "top"}, {"back" and "bottom"}, {"forward" and "up"}, {"backward" and "down"} and {"bring", "send" and "move"}.

- Only use the following terms:
Code: [Select]
Move
Forward, Backward
Front, Back

- Make the following changes:
Code: [Select]
bringToFront -> moveToFrontLayer
bringForward -> moveForwardOneLayer
sendToBack -> moveToBackLayer
sendBackward -> moveBackwardOneLayer

moveToBottom -> moveToBackInLayer
moveToTop -> moveToFrontInLayer
moveDown -> moveBackwardInLayer
moveUp -> moveForwardInLayer

- Deprecate the old function names and have them call the new ones.

- Make changes to the terminology in the Design Mode blocks to be consistent with the function names.


Issue updated by irock - February 13, 2020, 09:57:43 pm
  • Type changed from Bug to Suggestion


Issue updated by Justin - February 13, 2020, 10:54:42 pm
  • Tags added: 4.1.0, 5.0.0


Pages: 1

Details

  • Reported
    February 13, 2020, 09:57:36 pm
  • Updated
    February 13, 2020, 10:54:42 pm

  • View Status
    Public
  • Type
    Suggestion
  • Status
    New
  • Priority
    Normal
  • Version
    (none)
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Engine

Tags