Bug Issue: Last 2 betas haven't launched for me on Mac


Pages: 1

designpeg

  • Subscriber - Stencyl Studio
  • *
June 01, 2020, 08:41:26 am
Hi, I've not been able to open the last two beta versions. First error I get is related to java not being allowed to open on first run, I can get past this by opening java in the terminal and giving the os permission, but then I get the error in the attached log.


New attachment added by designpeg - June 01, 2020, 08:41:42 am


Luyren

  • Master Stencyler
  • *
June 01, 2020, 11:39:20 am
Code: [Select]
2020-06-01 16:36:02,286 INFO  [AWT-EventQueue-0] stencyl.sw.app.ExtensionManager: Toolset Extensions: [com.byrobingames.manager-0.0.1]
2020-06-01 16:36:10,675 ERROR [AWT-EventQueue-0] root: Unexpected problem on thread AWT-EventQueue-0: invalid version "null": non-numeric "null"
java.lang.IllegalArgumentException: invalid version "null": non-numeric "null"
at misc.Version.parseInt(Version.java:204)
at misc.Version.<init>(Version.java:142)
at misc.ShortVersion.<init>(ShortVersion.java:16)
at stencyl.sw.util.platform.ios.IOSDeviceManager.scanConnectedDevices(IOSDeviceManager.java:89)
at stencyl.sw.util.platform.DeviceManager.scanConnectedDevices(DeviceManager.java:46)
at stencyl.sw.SW.initLaunchConfigurations(SW.java:990)
at stencyl.sw.SW.showWindow(SW.java:769)
at stencyl.sw.SW.access$100(SW.java:159)
at stencyl.sw.SW$1.run(SW.java:255)
at java.desktop/java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
at java.desktop/java.awt.EventQueue$4.run(Unknown Source)
at java.base/java.security.AccessController.doPrivileged(Native Method)
at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.NumberFormatException: For input string: "null"
at java.base/java.lang.NumberFormatException.forInputString(Unknown Source)
at java.base/java.lang.Integer.parseInt(Unknown Source)
at java.base/java.lang.Integer.parseInt(Unknown Source)
at misc.Version.parseInt(Version.java:200)
... 21 more
The last thing checked before the error is the byrobingames extension. I don't know if it's failing on that extension, or on something else afterwards.


Justin

  • Master Stencyler
  • *
June 01, 2020, 05:04:37 pm
The Java problem is really unfortunate. It should meet Apple's requirements and run fine now, but I hit the same issue too, so I was hoping that it was only a problem on my computer. I saw another person post a similar story (failed on dev machine only) on the Apple developer forums. I'll take a closer look now.

------

About the later error, it looks like it's failing to parse information about connected iOS devices. Can you try running the following two commands in a terminal and post the output of each?

Code: [Select]
/Applications/Stencyl-b10538-mac/ext-tools/ios-deploy/ios-deploy -c

Code: [Select]
instruments -s devices
« Last Edit: June 01, 2020, 07:11:17 pm by Justin »


Justin

  • Master Stencyler
  • *
June 02, 2020, 05:02:35 am
Re: the Java problem, see the last post in #1690: Haxelib error.

(edit: fixed link to wrong post)
« Last Edit: June 02, 2020, 08:13:08 pm by Justin »


Issue updated by Justin - June 02, 2020, 08:14:09 pm
  • Tags added: 4.0.3


Issue updated by Justin - June 09, 2020, 09:56:45 pm
  • Tags added: mac


Issue updated by Justin - July 02, 2020, 05:23:23 am
  • Status changed from New to Need Info


designpeg

  • Subscriber - Stencyl Studio
  • *
July 02, 2020, 05:28:29 am
Hi Justin, I get
Marks-MacMini:~ markbawden$ instruments -s devices
Known Devices:
Mark’s MacMini [441B9A38-1C00-5F5D-AE80-D89586774D7D]
(null) [00008020-001854482698002E]
Apple TV (13.4) [71BC899F-E2CE-4753-8B3C-5BB76766C70D] (Simulator)
Apple TV 4K (13.4) [DCFBD4CF-C81A-4088-AD79-E5FE97C82968] (Simulator)
Apple TV 4K (at 1080p) (13.4) [A514EFB8-1769-49DF-A3FE-126392D09608] (Simulator)
Apple Watch Series 4 - 40mm (6.2.1) [B8AC8369-CD8B-4F6E-83CE-EA896DF03F3A] (Simulator)
Apple Watch Series 4 - 44mm (6.2.1) [814EFB8E-154E-4000-ABC5-8531C54994FE] (Simulator)
iPad (7th generation) (13.5) [E1EDF959-4959-422B-B968-B851130B95F1] (Simulator)
iPad Air (3rd generation) (13.5) [44DCE5A7-2FC2-4AA2-A0FC-6DC96EF33AE3] (Simulator)
iPad Pro (11-inch) (2nd generation) (13.5) [B8FB5A5B-330F-4770-96AC-8C2C4C421AF5] (Simulator)
iPad Pro (12.9-inch) (4th generation) (13.5) [7E6BBBC4-7B54-4297-A2CB-BBAAFD2C417F] (Simulator)
iPad Pro (9.7-inch) (13.5) [8C244EDE-AC84-4D12-968B-D655723B70F7] (Simulator)
iPhone 11 (13.5) [1D39490E-35B4-4147-9B9C-C74343015EAB] (Simulator)
iPhone 11 Pro (13.5) [44BF63F5-7333-4709-A07C-D9E378BCD465] (Simulator)
iPhone 11 Pro (13.5) + Apple Watch Series 5 - 40mm (6.2.1) [1AF20A2E-46D6-47DA-98E8-89CCCFF13651] (Simulator)
iPhone 11 Pro Max (13.5) [A6001841-F42A-4D3E-A87F-63934C03C206] (Simulator)
iPhone 11 Pro Max (13.5) + Apple Watch Series 5 - 44mm (6.2.1) [BFBAE118-77F7-42F9-8A5E-935EEF39A249] (Simulator)
iPhone 8 (13.5) [279AE304-D56B-48EC-BABB-B0BD4C2BDF2F] (Simulator)
iPhone 8 Plus (13.5) [12ECE506-47E7-4D57-8595-AD878B6AE5EA] (Simulator)
iPhone SE (2nd generation) (13.5) [DB05734A-D47A-41C0-A402-607E4049646C] (Simulator)

and:

Marks-MacMini:~ markbawden$ /Applications/Stencyl-b10568-mac/ext-tools/ios-deploy/ios-deploy -c
[....] Waiting up to 5 seconds for iOS device to be connected
[....] Found 00008020-001854482698002E (D321AP, iPhone XS, iphoneos, arm64e) a.k.a. 'iPhone' connected through WIFI.


Justin

  • Master Stencyler
  • *
July 02, 2020, 05:47:43 am
(Some more pertinent info in this thread)

---

Alright, thanks. I see where the null is coming in now. I'll fix Stencyl to account for that once I'm home in a few hours.

Though based on the workaround you found in your forum post, it seems like that may not have had anything to do with it. I guess we need to figure out how to make this work smoothly with devices connected via Wi-Fi.
« Last Edit: July 02, 2020, 05:50:31 am by Justin »


Issue updated by Justin - July 02, 2020, 05:51:14 am
  • Status changed from Need Info to Assigned
  • Issue Assigned from (none) to Justin


Justin

  • Master Stencyler
  • *
July 02, 2020, 02:29:28 pm
I've fixed the error related to iOS devices that stops Stencyl from loading in private build 10571 (slated for public release 4.0.3).

I do not know why your device appears as "null" though. I tried connecting mine via wifi, and everything appeared as normal. The only thing I could do to make mine show up as "null" was to revoke trust of my computer, and have it physically connected via cable.

Whatever this is, I'm guessing something must have changed on your end before early June, because the code that was causing problems here hasn't been changed in Stencyl in about a year and a half. It seems to be either a device state problem (in my case, again, revoking trust did it, but your case seems different), or some other bug in Apple's instruments program. Since we can't do anything about that, this issue is about as resolved as it's going to get.
  • Status changed from Assigned to Resolved


Pages: 1

Details

  • Reported
    June 01, 2020, 08:41:26 am
  • Updated
    July 02, 2020, 02:29:28 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Resolved
  • Priority
    Normal
  • Version
    3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Updating Stencyl

Tags


Attachments

* log-2020-06-01.zip (9.42 kB - downloaded 82 times.)