Bug Issue: El Capitan prevents games from running (breaks 'Neko')


Pages: 1 2

Jon

  • Chief Stencyler
  • *
September 24, 2015, 12:38:05 pm
Which in turn breaks running games. Third party issue, but we'll be getting more reports about this soon...

http://community.stencyl.com/index.php/topic,44175.0.html


Issue updated by Jon - September 24, 2015, 12:38:18 pm
  • Priority changed from 2 to 3
  • Status changed from New to Confirmed


Issue updated by Justin - September 24, 2015, 08:02:02 pm
  • Issue Assigned from (none) to Justin


Jon

  • Chief Stencyler
  • *
September 27, 2015, 03:03:07 pm
El Capitan will come out on Wednesday. Let's get this in and tested before people upgrade en masse and hit this issue.
« Last Edit: September 28, 2015, 10:38:29 am by Jon »


batuhancan

  • Level 2 Stencyler
September 28, 2015, 08:51:13 am
I'm available to test this as soon as needed.


Justin

  • Master Stencyler
  • *
September 28, 2015, 08:19:46 pm
I'll fix this tomorrow.


Justin

  • Master Stencyler
  • *
September 30, 2015, 02:43:09 am
It took longer than expected, but I've committed a potential fix in b8705. Try it out and let me know if it works. Thanks. :)


Issue updated by Justin - September 30, 2015, 02:51:29 am
  • Status changed from Confirmed to Resolved


batuhancan

  • Level 2 Stencyler
September 30, 2015, 09:56:29 am
Thank you Justin.
After updating, it tells me first of all that my workspace is not writable and I suddenly had to login again.
While compiling it wants to install neko, but apparently the neko-install folder isn't there.

I installed neko myself, but I'm getting a different error now, even on flash, which used to work fine.

2015-09-30 18:44:44,683 INFO  [Thread-12] stencyl.sw.util.StreamGobbler: [haxelib] sh: neko: command not found
2015-09-30 18:44:44,684 DEBUG [pool-1-thread-2] stencyl.sw.util.Util: Process 'haxelib' exited with code: 127


Justin

  • Master Stencyler
  • *
September 30, 2015, 10:19:26 am
Could you post your logs? I need to make sure we can do this without the user installing neko on their own.

Regarding your attempt to run with your own neko install, we expect neko to be installed in a specific place, so either the neko install script we provide has to be followed, or the most recent ones provided by openfl.


New attachment added by batuhancan - September 30, 2015, 10:30:13 am


batuhancan

  • Level 2 Stencyler
September 30, 2015, 10:35:37 am
There you go.
For the installation I used the script provided here https://github.com/HaxeFoundation/haxe/issues/4483


Justin

  • Master Stencyler
  • *
September 30, 2015, 10:40:51 am
Can you confirm that the file "/Applications/Stencyl-full/plaf/install_neko" exists for you?

Can you successfully run this in the terminal?
chmod 755 /Applications/Stencyl-full/plaf/install_neko

If that works, can you run this?
/Applications/Stencyl-full/plaf/install_neko


Issue updated by Justin - September 30, 2015, 10:42:56 am
  • Status changed from Resolved to Need Info


batuhancan

  • Level 2 Stencyler
September 30, 2015, 10:53:21 am
File or folder's not there.
« Last Edit: September 30, 2015, 10:54:11 am by batuhancan »


Jon

  • Chief Stencyler
  • *
September 30, 2015, 10:54:35 am
Which folder?


batuhancan

  • Level 2 Stencyler
September 30, 2015, 10:56:33 am
Meant the install_neko file


Justin

  • Master Stencyler
  • *
September 30, 2015, 11:03:40 am
Great, thanks. Looks like the file was being stripped out by our build packager. b8706 includes it.

What do you get from running this in the terminal?
echo $PATH

And do you have a file at /usr/local/bin/neko?
« Last Edit: September 30, 2015, 11:04:27 am by Justin »


batuhancan

  • Level 2 Stencyler
September 30, 2015, 11:14:34 am
echo $PATH gives me /Applications/Stencyl/plaf/neko-mac:/Applications/Stencyl/plaf/haxe:/Applications/Stencyl/plaf:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin

and /usr/local/bin/neko did contain my neko installation, but I just wiped it to see if Stencyl will install it correctly.


batuhancan

  • Level 2 Stencyler
September 30, 2015, 11:19:25 am
Cool, it installed fine and my game is compiling for iOS right now.


Justin

  • Master Stencyler
  • *
September 30, 2015, 11:48:40 am
Great, thanks for the help.
  • Status changed from Need Info to Closed


Pages: 1 2

Details

  • Reported
    September 24, 2015, 12:38:05 pm
  • Updated
    October 07, 2015, 08:14:10 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Closed
  • Priority
    High
  • Version
    Stencyl 3.3
  • Fixed in
    (none)
  • Assigned to
    Justin
  • Category
    Compiling/Testing Games

Tags


Attachments

* log-2015-09-30.zip (2067.23 kB - downloaded 94 times.)