Bug Issue: Could not open game- Could not restore from backup


Pages: 1

bobbricks2300

  • Junior Stencyler
November 16, 2016, 06:25:40 am
Hi,
Today when I was testing my game Stencyl gave me multiple 'Actor can not have zero-frame animation' messages while compiling, and then told me to close without saving and reopen. I did, and when I attempted to reopen the game, it gave me the Could not open game- Could not restore from backup screen. I checked the xml files, and the game.xml looked fine, but the xml.bak was blank.
Is there any chance of fixing this, or will I have to use my last backup?


Issue updated by rob1221 - December 26, 2016, 04:49:27 pm
  • Category changed from Engine to Dashboard


rob1221

  • Master Stencyler
  • *
March 29, 2017, 09:57:00 am
If you can describe what caused the corruption that would help.  You've probably moved past this issue by now but I'll leave this here for others who might see this.

If you did not try running the game after the corruption happened then there may still be a copy you can use.  Go to your workspace and check games-generated/GAME_NAME/assets/data/resources.xml.  If that file looks normal (standard xml stuff rather than garbage), you can copy all the text from that file and replace games/GAME_NAME/resources/data.xml.
  • Status changed from New to Need Info


Issue updated by Justin - July 10, 2018, 11:39:37 pm
  • Status changed from Need Info to Closed


Pages: 1

Details

  • Reported
    November 16, 2016, 06:25:40 am
  • Updated
    July 10, 2018, 11:39:37 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Closed
  • Priority
    Normal
  • Version
    3.4.0 beta2
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Dashboard

Tags