Bug Issue: Crash Course isn't working even after doing all of the steps


Pages: 1

Jackblue

  • Junior Stencyler
October 13, 2015, 11:25:24 am
I just finished the crash course on my macbook air then I tried to run it on flash player and flash browser but it said,encountered errors while building game so generate logs and post them on forums.


captaincomic

  • Master Stencyler
  • *
October 13, 2015, 02:52:14 pm
Quote
generate logs and post them on forums.
Please attach your logs (Debug -> Logs -> Generate Logs).
  • Status changed from New to Need Info


New attachment added by Jackblue - October 13, 2015, 03:07:19 pm


Jackblue

  • Junior Stencyler
October 13, 2015, 03:08:27 pm
I added the logs


captaincomic

  • Master Stencyler
  • *
October 13, 2015, 03:11:42 pm
Never mind, I saw you posted them here:
http://community.stencyl.com/index.php/topic,44659.0.html

This is the error:
Code: [Select]
[2015-10-13 09:23:04,477 DEBUG [pool-1-thread-12] stencyl.sw.util.Util: Running command: [plaf/neko-mac/neko, /Users/jesushernandez18/Downloads/Stencyl:Kits:Game Prototypes/Stencyl-full 2/plaf/haxe/lib/lime/lime/tools/tools.n, -verbose, build, -debug, project.xml, flash, -openfl, /Users/jesushernandez18/stencylworks/games-generated/Crash Course Game/]
2015-10-13 09:23:04,589 INFO  [Thread-27] stencyl.sw.util.StreamGobbler: [neko] Called from <null pos> line 0
2015-10-13 09:23:04,589 INFO  [Thread-27] stencyl.sw.util.StreamGobbler: [neko] Uncaught exception - load.c(237) : Failed to load library : std.ndll (dlopen(std.ndll, 1): image not found)

It's a problem with OpenFL/neko. Did you get a prompt to install the Neko VM?


Jackblue

  • Junior Stencyler
October 13, 2015, 03:19:04 pm
No I didn't so I need to Install it ?


captaincomic

  • Master Stencyler
  • *
October 13, 2015, 05:10:28 pm
Ah, sorry, no, you don't. Only if you're on El Capitan.

Maybe the colons in your path are causing the problem:
Code: [Select]
/Users/jesushernandez18/Downloads/Stencyl:Kits:Game Prototypes/Stencyl-full 2/plaf/haxe/lib/lime/lime/tools/tools.nDoes it work if you move Stencyl to /Applications/ ?
 
« Last Edit: October 13, 2015, 05:10:55 pm by captaincomic »


Jackblue

  • Junior Stencyler
October 19, 2015, 11:05:10 am
No that didn't solve it


captaincomic

  • Master Stencyler
  • *
October 19, 2015, 05:57:03 pm
Are you still getting the same error after moving Stencyl?
"Failed to load library : std.ndll (dlopen(std.ndll, 1): image not found)"
« Last Edit: October 19, 2015, 05:57:24 pm by captaincomic »


Jackblue

  • Junior Stencyler
October 19, 2015, 07:15:07 pm
I am unsure I am attaching the second logs


New attachment added by Jackblue - October 19, 2015, 07:19:53 pm


captaincomic

  • Master Stencyler
  • *
October 27, 2015, 04:57:18 pm
There is a different error now: The .scn file for your second scene is missing.
Code: [Select]
java.io.FileNotFoundException: Source '/Users/jesushernandez18/stencylworks/games/Crash Course Game/scenes/1.scn' does not exist

You can try deleting the second scene.


Jackblue

  • Junior Stencyler
October 27, 2015, 08:02:07 pm
I deleted the second scene but it still wouldn't run so I deleted it and made a new game which worked as it now runs I am fine.Thank you for your help.
« Last Edit: October 27, 2015, 08:02:41 pm by Jackblue »


Issue updated by captaincomic - October 27, 2015, 09:15:07 pm
  • Status changed from Need Info to Closed


Pages: 1

Details

  • Reported
    October 13, 2015, 11:25:24 am
  • Updated
    October 27, 2015, 09:15:07 pm

  • View Status
    Public
  • Type
    Bug
  • Status
    Closed
  • Priority
    Normal
  • Version
    (none)
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    (none)

Tags


Attachments

* Crash Course Logs .zip (21.32 kB - downloaded 32 times.)
* Crash Course Logs 2.zip (17.22 kB - downloaded 36 times.)