[SOLVED] Unexpected problem on thread AWT-EventQueue-0


  • Posts: 73
Each time I'm about to implement a large change to my game I do a 'save as' and increment the version number, which is what I just did. Then I tried to open the new save and was hit with a vague error message saying I should post my logs and describe the problem.

I deleted Game v012, opened Game v011 and repeated the Save As process. Upon opening Game v012 I was hit with the same error again, confirming that the error was recreatable and didn't happen by chance the first time. I had a look at the log and the issue seems to be something Java related.

Getting a bit fed up with troubleshooting engine issues rather than working on games tbh.. F@#king Java.  Apart from what the error is and how to fix it, can someone explain why this problem-child of a language is even a part of Stencyl's backbone?

« Last Edit: January 30, 2020, 07:26:38 am by ichimitch »


  • *
  • Posts: 2754
First: when creating back ups of your game, I personally recommend you export them instead of saving as (File > Export). You can rename the exported file without problems as far as I know. At least that's what I do. In my case, if I want to revert to an older version, I usually delete the version I was working on (backing that up on a case by case basis).

Second: you're getting an index out of bounds error, but it seems different from the old one from 4.0.1. It happens right as it tries to read your scene 0 xml file, so it seems scene related. I have one game that I did "save as" to, and I do get a pop up when I open it, but otherwise the game tests fine (I've been procrastinating to post about that, to be honest). Is this the same case for you, or is the game refusing to test at all? You could try opening all your scenes, then saving your game, and see if you still get the error.

Third: since it's an index out of bounds error (and if you can't test your game at all), you could try what's described here: http://community.stencyl.com/index.php?issue=1552.0

Lastly: touch controls and mouse controls are the same (they use the same blocks), so you could meanwhile work on your game testing in either Windows or HTML5, using the mouse to control it. At least until you can get help from someone more experienced with the mobile stuff.

My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.


  • Posts: 73
Thanks Luyren, you're amazing as always.

Yes after I close the error message everything seems to be okay. I posted about it anyway because I was concerned that it may be related to the problems I've been having trying to get Android NDK and SDK itergrated, but if it's scene related I guess not.

I'll adopt your save practices, thanks.

« Last Edit: January 30, 2020, 07:38:48 am by ichimitch »