Max String Sized Reached - HELP!


  • Posts: 9
So I have had this issue pop up before but have been able to fix it. This time I noticing an issue I can't get past.

I have an actor that has a total of 26 animations to it. Each animation is actually just a small single frame png file (less then 300x150 in size).

The game can compile just fine up to 20 animations for the actor. However, when I add any more it, even if it is just one more, I get the "cannot compile, yada yada, max string size reached" issue.

I know the png pixel size is small, as I have double checked each png used in the actor in photoshop. Each one is exactly the same dimension. I am not scaling, each one is 1x.

I don't understand - is there another reason I would be getting this issue? Once I get the issue, even if I remove the actor I was modifying, I still get the issue - as if the actor is still being calculated into the compile. I use the clean up project and unused files and I still get the issue.

Anyone have any why this happens only when I increase the actors animation count to over 20?


  • Posts: 129
try to create a new blank game and export all the codes back into it. and try again possibly the game is damaged, in some code.


  • *
  • Posts: 2738
Did you disable the 4x scales in the game settings?