[SOLVED] Game will run in FlashPlayer 10 but not in FlashPlayer11 ?


  • Posts: 1

I have been making a new version of a snake game, so I had a look at the snake kit in the StencylForge, and it seemed to work fine, I made allot of changes, and it all works perfectly well.

Then I tried it in a browser, and it loads up fine, but seems to just sit there, not responding to key strokes, and actually not hiding sprites that should be hidden at startup. The music keeps playing though, and the animations of a sprite (fruit) seems to be playing fine.

I checked the logs, and they are saying that the Test In Flash initialized fine.

I run it again in flash player 10 standalone (windows 7) and it worked perfectly, I ran it in FlashPlayer11 standalone, and it does the same thing as the latest web plugin for browsers (IExplorer and Chrome).

Just for a test, I loaded up the vanilla snake kit, and tested it without modification, and it does exactly the same thing, it loads initializes and then sits there doing nothing. It also works perfectly well in FlashPlayer 10.

Any ideas ?

OK, sorry about that, it works fine, I was initializing something before it was actually created (in my version of the game).

Printing to the console works great to dig up silly runtime errors like that.


« Last Edit: September 29, 2012, 07:56:21 am by davlexdesign »
This is just a little something I've been working on for a while now ....