Shortcut "Starting Directory" User-error/bug (Windows XP)

Hectate

  • *
  • Posts: 4645
I was going to do some uploading of my old games via the new b368 so I tried to compile and run HBGolf to see what needed fixing. Oddly though, I found that I couldn't open any behaviors - with a bunch of odd stuff in the log too.
Examining the situation I discovered that when I copied my SW installation to a new "B368" directory from the  "B340" directory (to backup the original) I did the upgrade correctly - but I missed something when updating my shortcut. Apparently Windows allows you to choose a directory to "Start in" - which was still set for B340. The result was that my B368 stencylworks.exe was launching - but pulling everything in the b340 directory and causing SW to silently falter at various points - for example, behaviors would not open but the spinner would sit there saying "opening" making it seem that it was still trying.

I can't imagine this will be an issue for too many other people, but it's something to consider for the future. I included a screenshot of the shortcut's settings (corrected) where you can see what it did if you're curious.
:
:
Patience is a Virtue,
But Haste is my Life.
Proud member of the League of Idiotic Stencylers; doing things in Stencyl that probably shouldn't be done.

Hectate

  • *
  • Posts: 4645
OK, maybe this wasn't it. My b340 folder has a broken installation of b368 and my b368 folder has my b340 installation. :P

I'll try re-installing.
:
:
Patience is a Virtue,
But Haste is my Life.
Proud member of the League of Idiotic Stencylers; doing things in Stencyl that probably shouldn't be done.