Open URL in browser gets blocked by pop-up blockers.

pyshka

  • *
  • Posts: 23
Is there any solution to opening URL in a new tab (maximized, not pop-up window)? Pop-up window gets blocked by Chrome's blocker. I saw that rob1221 has made a behavior to tackle this problem in 2.2, can we have some solution or control over the open URL block in 3.0?

Jon

  • *
  • Posts: 17533
Currently, we're using this which is pretty much a textbook Flash approach:

Lib.getURL(new URLRequest(URL));

I'm happy to change it to a different thing, if I can procure the details.

rob1221

  • *
  • Posts: 9474
My behavior doesn't change how the URL is opened, but what triggers it, a click event listener.  AFAIK it's a security thing.

pyshka

  • *
  • Posts: 23
Yes, basically all I need is an event listener. I've tried to edit AS behavior of yours without any luck. Any plans on translating that so it works on 3.0?

rob1221

  • *
  • Posts: 9474
Yeah, try this and see if it solves the problem.

pyshka

  • *
  • Posts: 23
Thank you for your help! You attached just an icon though, not the behavior :) There is just an icon attached on your 2.2 post as well.

rob1221

  • *
  • Posts: 9474
That's how behaviors are imported/exported, as PNGs.

pyshka

  • *
  • Posts: 23
Sorry, never tried to import behavior before. Thanks for your help once again, it works and it will be useful to a lot of people, as this question pops up a lot in the forums.

« Last Edit: January 30, 2013, 11:34:58 pm by pyshka »

makarone

  • Posts: 15
Hey Rob, thanks for the behaviour!
Is it possible to make links work in IE11? It's still blocks the outgoing links ;(
How can i edit it for ie?
Btw cpmstar links work fine  in ie11, no blocks.



rob1221

  • *
  • Posts: 9474
I haven't heard about that problem before and I don't know why it isn't working.

makarone

  • Posts: 15
please try this link in IE11
http://miniduck.ru/link/
without html file it works good http://miniduck.ru/link/bub.swf

in other browsers it's also work fine.

It would be awesome to find a solution!


UPD:
Everythinhg works fine.
Seems like it was bad html file.

« Last Edit: May 10, 2014, 03:46:34 am by makarone »