Errors when compiling the file.

AtlanticCG

  • Posts: 113
Get the following error when compiling the build:

"While reading / Users/StencylBuild/temp/graphics/1x/atlas0.png pngcrush caught libpng error:
    PNG unsigned integer out of range. "

AtlanticCG

  • Posts: 113
I was looking for information about this error on other sites, nothing concrete has been able to find. Apparently, there is also no one had to deal with this

AtlanticCG

  • Posts: 113
It is interesting - despite the error in the log, the game runs on an iPhone 4, but crashes when loading on iPhone 3gs. At first I thought that this is due to the fact that not enough memory. But looking at the log more closely, I realized that the problem is in the atlas for X 1.
in versions that are working normally, both atlas generated. and the latest version is only generated atlas for Retina, and it turns out to 3gs defective (Photoshop can not open it).
I tried to reduce the atlas by 50% and save instead of the defective atlas, but while Stencyl is compiling the build, it again replaces it with the defective.
At this point in the forum to find a similar problem but could not.
Help please

AtlanticCG

  • Posts: 113
I upgraded the version of the Stencyl to 2.2, but now I get to log the error message: error: / Users / StencylBuild / temp / graphics x tlas0@2x.xml: No such file or directory

Is there anyone at all? :)
Please forgive me for my importunity,  but I really do not know how to fix this bug
tnx

AtlanticCG

  • Posts: 113
People can not anybody familiar with this bug? I've tried everything, reinstalled Stencyl, downloaded the update, but it still can not build an atlas and in the log it gives to the file the erroneous name: instead of the atlas - x tlas0@2x.xml
if nobody of the users do not know how to solve it, it will be one of the developers?
many thanks

captaincomic

  • *
  • Posts: 6108
I'm not familiar with that error and a search didn't bring up much. Maybe there is something else in the logs that points to the problem. Please attach your full logs.

Joe

  • *
  • Posts: 2478
This looks like a case of the atlas's name getting mangled. If you open the logs in a text editor that supports Unicode, you'll probably see a Unicode character where that first "x" is.

We haven't touched the 2.x series in some time and would strongly encourage you to use the 3.0 beta.

AtlanticCG

  • Posts: 113
2Captaincomic:
I attached a file here. I see the error, but do not know how to get rid of it.
If you can solve it, it would be great.

2Joe:
Yes, I think you're close to the truth, but what can I do here?
I'd love to be moved to 3.0, but apparently I do not understand it with the new version. Build compiles a long time and some features (such as swiping) simply don't work  :(

Thank you for the help guys

« Last Edit: June 01, 2013, 11:01:30 pm by AtlanticCG »

AtlanticCG

  • Posts: 113
At first I thought it was because of what is my wrong actions.
But yesterday I tried to compile the build of an older version, which should work. And now it gives the same error, despite the fact that previously did not give out. Does this mean that the problem is in the Stencyl? Or was it something else?