Cannot test/publish

darrigaz

  • *
  • Posts: 124
I booted stencyl up after a week long absence and discovered that to my horror I can no longer publish or test my game. I can't even test individual scenes. I tried removing the music files which were about the most recent thing I added (I gather that's a common source of this bug)but to no avail. I'm quite confused as I published and tested a build before I shut down stencyl last time and haven't changed anything since.

I've attached my log files. Anyone able to tell me what I'm looking for?

« Last Edit: October 26, 2013, 08:59:53 am by darrigaz »

darrigaz

  • *
  • Posts: 124
No one? I've tried deleting all the sound files, removing actors I've worked on recently, poking through the log files on my own with no knowledge of what I'm looking for, exporting the other game I've been working on (which still exports and tests fine).

I'm totally at a loss and it'd be a damn shame to have to abandon a project that I've almost finished.

The worst bit is I get no error message, just a series of compiling bars and then nothing.

rob1221

  • *
  • Posts: 9474
Quote
A file found in a source-path must have an externally visible definition. If a definition in the file is meant to be externally visible, please put the definition in a package.
Unless you're using AS3 incorrectly this typically means file corruption, but it's not clear where.  I suggest backing up your game and then deleting resources one at a time until your game can compile.  Then restore from backup and redo whatever resource broke.

darrigaz

  • *
  • Posts: 124
Thank you! I should've stayed calm and tried that first. Turns out my end of scene teleporter behaviour had lost all the scene attributes I'd set up for each instance of it. Replacing them all and restarting fixed it.

I moved all my levels into a folder recently is that likely to have been the cause?

rob1221

  • *
  • Posts: 9474
Probably.  You should rarely need to change anything inside the game's resource folder.