Game fails to preview or export...

zerosimms

  • Posts: 710
Seems there's a number of these posts floating around at the moment and the same has just happened to me running Stencyl 2.2.0.

I've tried a number of things including:
Deleting actors
Deleting Scenes
Resaving the game
Exporting, re-importing game
Disabling all behaviors

Yet every build get's so far then... nothing.
I've spent two days (seriously) trying to sort this myself and now I need some help, I need to get this game done for the jam :)

Please can someone help me, the output always seems to complain about the following:

[LOG] Loading configuration file /Applications/>Game Dev Tools/Stencyl/ext-tools/flex/frameworks/flex-config.xml


Full logs attached and thanks for any help in advanced

rob1221

  • *
  • Posts: 9474
Your workspace is showing up with the > symbol in it which is odd and I don't know what that means.

zerosimms

  • Posts: 710
Ha Ha I do :) (see attached)

Though I can't see why that would have an affect, I've had my laptop set up this way for some time now :(

rob1221

  • *
  • Posts: 9474
If you didn't change versions or your workspace in a while then that probably isn't the problem.  Just backup your game and start deleting resources one at a time until the game compiles.  Then go back to your backed up game and replace that broken resource.

zerosimms

  • Posts: 710
This is crazy, day four and it's still failing to build. I've done removing actors and code until it works and it doesn't. What I have discovered after using time capsule to get my game back :) is that adding a new scene causes the game to stop previewing.

Any help please? I'm not going to make this deadline otherwise :(

rob1221

  • *
  • Posts: 9474
I don't see any more specific information in that log.  If you send me the game project I'll take a look at it.

zerosimms

  • Posts: 710
Hey Rob I have PM'd you. Thanks for taking the time out on this one!

rob1221

  • *
  • Posts: 9474
Inside your game folder, open the snippets folder and delete SceneEvents_1.design.  Your game should build after that.

zerosimms

  • Posts: 710
WOOO HOOO!!! Thank you so much Rob, that worked a treat! Thank you so much!

Do you know what happened or how it's caused?

rob1221

  • *
  • Posts: 9474
One of your scenes wasn't deleted properly, but I don't know how it happened.