[Closed]Error at an application launch on Simulator

snake302

  • Posts: 10
Helloy, when i bild app, I have got EROR
 
Code: [Select]
library not found for -lStencyl Command /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/llvm-g++-4.2 failed with exit code 1-
What to do?

Здраствуйте, при запуcке приложения на симуляторе выскакивает ошибка:
Code: [Select]
Library not found for -lStencyl Command /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/llvm-g++-4.2 failed with exit code 1что мне сделать, что бы исправить ошибку?

Update: All thanks! The problem is solved! Has downloaded updating, all works!




« Last Edit: August 13, 2011, 12:36:20 pm by snake302 »
Russan Developer!

На форуме общаюсь по Английски, в ЛС только на Руском At a forum I communicate on English, in PM only on Russian 

mikbob

  • Posts: 493
Helloy, when i bild app, I have got EROR
 
Code: [Select]
library not found for -lStencyl Command /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/llvm-g++-4.2 failed with exit code 1-
What to do?

Здраствуйте, при запуcке приложения на симуляторе выскакивает ошибка:
Code: [Select]
Library not found for -lStencyl Command /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/llvm-g++-4.2 failed with exit code 1что мне сделать, что бы исправить ошибку?
Is the error from console?
Let me try: Является ли ошибки из консоли?

Visit Our Site!  http://www.mikbobgames.com
Play The Platforms 2!  http://bit.ly/theplatforms2
Check out our twitter!  www.twitter.com/mikbobgames

Jon

  • *
  • Posts: 17533
Do you have the iOS SDK installed? If so, what version of it?

snake302

  • Posts: 10
Xcode 4.2 and iOS 5 SDK beta for Lion


The console didn't look, hardly later a screenshot I will give


---------------

As that is strange, has made reboot writes an error at start: The file “Info.plist” doesn’t exist
In the console it is empty

Консоль теперь молчи

« Last Edit: August 12, 2011, 10:27:48 am by snake302 »
Russan Developer!

На форуме общаюсь по Английски, в ЛС только на Руском At a forum I communicate on English, in PM only on Russian 

Jon

  • *
  • Posts: 17533
What is confusing me is that you say that you were trying to launch in the simulator, but this line:

library not found for -lStencyl Command /Developer/Platforms/iPhoneOS.platform/Developer/usr/bin/llvm-g++-4.2 failed with exit code 1

Says that it's trying to launch on the device.

Please outline the exact steps you are taking. For example...

1) I launched StencylWorks
2) I opened Game
3) I clicked on "Test Game" (NOT "Test Game (Device)")
etc.

Posting the game as a ZIP file will also be helpful.

Thanks!

snake302

  • Posts: 10
1. I ran StencylWorks
2. Select game Ctapult
3. Pressed the Test game (Device)
4. In Xcode clicked RUN (selected iOS Device, iPad is connected)
5. error: The file "Info.plist" doesn't exist.

Same as if through Xcode choose Simulator
Russan Developer!

На форуме общаюсь по Английски, в ЛС только на Руском At a forum I communicate on English, in PM only on Russian 

Jon

  • *
  • Posts: 17533
Does it run if you click 'Test Game' through the app but don't open in Xcode, so it runs in the simulator directly from StencylWorks?

Is there an Info.plist file in the Xcode project's directory? (there shouldn't be)
How about Application-Info.plist? (there should be)

Could you take a screenshot of the project, opened in xcode with the "Resources" tree item expanded, so I can see what's under it? Here is what mine looks like.

Jon

  • *
  • Posts: 17533
Another clue for you - screenshot this screen.

Targets > AppScaffold > Build Settings
Search for "info." and then screenshot

It should look like my screen.

http://www.rhonabwy.com/wp/2008/01/21/tweaking-xcode-build-configurations-aka-infoplist-is-missing/

snake302

  • Posts: 10
On a simulator without xcode works.
Well here again old error !
http://puu.sh/4j0e
http://puu.sh/4j0n
I Delete "libStencyl.a"
And have EROR!
http://puu.sh/4j0r
I-am stupid??
Russan Developer!

На форуме общаюсь по Английски, в ЛС только на Руском At a forum I communicate on English, in PM only on Russian 

Jon

  • *
  • Posts: 17533
Deleting libStencyl.a is a bad thing. It's the Stencyl engine, so deleting it will make the game not run.

What is the exact device model you have? Is it an iPhone 3G/3GS or an iPod Touch 2G or 3G?

If you upgrade to b28 and you are using those older devices, it will work. (Read "How to Update")
http://community.stencyl.com/index.php/topic,2479.0.html

If not, please grab the screenshots I requested in my previous reply.


snake302

  • Posts: 10
I Use iPad2 (Wifi)

Russan Developer!

На форуме общаюсь по Английски, в ЛС только на Руском At a forum I communicate on English, in PM only on Russian 

mikbob

  • Posts: 493
I Use iPad2 (Wifi)


You said that you were using ipad2 when it is in ios5 iphone simulator mode.

Visit Our Site!  http://www.mikbobgames.com
Play The Platforms 2!  http://bit.ly/theplatforms2
Check out our twitter!  www.twitter.com/mikbobgames

snake302

  • Posts: 10
I DOWNLOAD UPDATE! AND GAME WORKS ON MY IPAD!!! THANKS!!!
Russan Developer!

На форуме общаюсь по Английски, в ЛС только на Руском At a forum I communicate on English, in PM only on Russian 