[SOLVED] Problem with special chars in dialogs.

Ken Sowyer

  • Posts: 23
Here I am again  ::)
When I create a new Stencyl font, the program generates a bitmap of it, with all chars, right? á, ç, ã, etc...

But I can't use in the dialogs. It compiles, but when comes to "write" the char, Stencyl gives me this:

Code: [Select]
TypeError: Error #1009: Não é possível acessar uma propriedade ou um método de uma referência de objeto nula.
at DialogFontInfo/getScaledImg()[D:\Stencyl_workspace\stencylworks\engine-extensions/dialog/src/DialogFontInfo.hx:254]
at DialogFont/createChar()[D:\Stencyl_workspace\stencylworks\engine-extensions/dialog/src/DialogFont.hx:76]
at DialogFont/getScaledChar()[D:\Stencyl_workspace\stencylworks\engine-extensions/dialog/src/DialogFont.hx:63]
at BitmapDataUtil$/drawChar()[D:\Stencyl_workspace\stencylworks\engine-extensions/dialog/src/BitmapDataUtil.hx:156]
at DialogBox/messageStep()[D:\Stencyl_workspace\stencylworks\engine-extensions/dialog/src/DialogBox.hx:378]
at DialogBox/update()[D:\Stencyl_workspace\stencylworks\engine-extensions/dialog/src/DialogBox.hx:507]
at Dialog/updateDialogBoxes()[D:\Stencyl_workspace\stencylworks\engine-extensions/dialog/src/Dialog.hx:392]
at Dialog/dialogUpdater()[D:\Stencyl_workspace\stencylworks\engine-extensions/dialog/src/Dialog.hx:149]
at com.stencyl::Engine$/invokeListeners2()[C:\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Engine.hx:4022]
at com.stencyl::Engine/update()[C:\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Engine.hx:2405]
at com.stencyl::Engine/postUpdate()[C:\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Engine.hx:2632]
at com.stencyl::Engine/onUpdate()[C:\Stencyl\plaf\haxe\lib/stencyl/1,00/com/stencyl/Engine.hx:2625]

I tried change my Windows Region configurations and different keyboard sets.

What I have to do?!

Ps: I'm from Brazil.


« Last Edit: December 21, 2014, 12:14:29 pm by Justin »

Justin

  • *
  • Posts: 4714
Are you using a normal Stencyl-generated font or are you using your own bitmap font?

I'll take a look if you send me your game.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

Ken Sowyer

  • Posts: 23
Quote
Are you using a normal Stencyl-generated font or are you using your own bitmap font?
Normal Stencyl-generated font.

I'm testing in the sample game...

Here's the image of the font created in the resources folder (yep.. green):

Ken Sowyer

  • Posts: 23
Here's the game if you wanna see it runs right there...

Justin

  • *
  • Posts: 4714
Okay, so I looked at the game you sent me and I found that Stencyl wasn't actually generating any of the accented characters for the compiled game. I guess setting the font to "Everything" only has it generate the typical English characters. Try opening your font, set Charset to "Custom" and type in all the characters you want in the "Characters" field. (Including A - Z, a - z, all the common stuff, and all the accented characters you need.)
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

Ken Sowyer

  • Posts: 23
Yep, it works! Thanks!!