[Solved] Android Test Game - Compiling, Finishing, and Nothing Happens


  • Posts: 17
Just decided to test a game on a real device.

After some initial issues of getting the whole thing going:
- Initial errors about not having the jdk/android sdk: JDK8 Didn't work, got 6 and set new location
- Errors Compiling and Permission Errors in Log: Erroneously ran 'android-setup.sh' with sudo, which lead to obvious permission errors. I deleted the folders the script made, and then ran the script again without sudo (just chmod +x)
- Making Sure Device was Discovered: Android Device Manager (run from inside Stencyl) displayed my phone as ?'s (just a series of question marks) under every column. The Yuri's comment (the second like with 'ATTR...') fixed it (I installed adb from the software center (Ubuntu) to test it out. Running 'adb devices' showed the devices properly after unplugging, and plugging it back in. It showed up in the Android Device Manager  (run from inside Stencyl) also showed the devices properly.

My current issue is the fact that when I try to run "Test Game" after selecting "Android" from the dropdown, it all seems to be going great.  "Saving", "Finalizing", "Compiling", and then absolutely nothing. I don't even get anything interesting in the log (attached). I found nothing on the forums about this issue.

tl;dr: Compiling game to test on android (no certificates or anything) set. I get "Saving", "Finalizing", "Compiling", and then nothing happens. Would really like to be able to test game on a real android device.

Edit: Removed Log attachment from post after having found the following line in the last log:

2015-01-29 21:51:13,151 INFO  [Thread-41] stencyl.sw.util.StreamGobbler: /home/user/Documents/stencylworks/android-sdk/android-sdk-linux/tools/ant/build.xml:483: The SDK Build Tools revision (19.0.0) is too low for project 'Name of the Game'. Minimum required is 19.1.0

Running Android SDK Manager (Launched from Android Device Manager > Window > Android SDK Manager) and installing everything under the "Tools" folder (including 19.1.0).  This solved everything. Game compiled and launched on phone.

Mods, feel free to delete this post or move it to a more appropriate area.

« Last Edit: January 29, 2015, 07:30:38 pm by spaceman »


  • *
  • Posts: 4714
I'll move it to resolved questions. It's useful for others who run into the same problems, so thanks for sharing what you did to get things working!
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)


  • Posts: 1
I hope this is an easy fix. I've have been trying to test my game on android 7 platform, but I get errors.

In the log file I get errors like this:

ERROR: The process "neko.exe" not found.
ERROR: The process "adb.exe" not found.
ERROR: The process "arm-linux-androideabi-g++.exe" not found.
ERROR: The process "cc1plus.exe" not found.
ERROR: The process "tail.exe" not found.
ERROR: The process "ios-sim.exe" not found.
Please help.


  • *
  • Posts: 9473
Justin asked you for full logs in the issue tracker.  Please go and attach them there and don't bump up old threads like this.