Stencyl 3.3 - 64-bit iOS, Google Purchases v3, Design Mode improvements

Hi, recently I install new Stencyl 3.3.2. At first, there's some popup error, it says "need permission workspace" or something. How to resolve that. And when I try following the crash course kit at Youtube. I can't use control behavior, such as Walking, Jumping or default control. But if I tried with Stencyl 3.2, it works fine. Sorry for my language since English isn't my mother tongue.


  • *
  • Posts: 6108
Try running Stencyl as administrator.


  • Posts: 6
Good to know!



  • Posts: 6
Good to know! (I'g generating my logs)

I run
Try running Stencyl as administrator.
I tried run as administrator, but It won't resolve the problem, the control still won't work, I think I have to downgrade the stencyl to 4.2.


  • *
  • Posts: 6108
dreamlayerstudio, but I assume running as administrator made the permission problem go away? For your other problem, please create a new thread in "Ask a Question" and describe what is not working in detail.

Skient, for you the same, please create a new thread and describe what problem you have.


  • Posts: 376
What is today's major changes?


  • *
  • Posts: 2181
Just look in Version Histroy to find the builts. But to find out the daily bug fixes and nightly builds you have to be a subscriber.

Public Releases ( Non-Subscribers, Free version of Stencyl) :
Build 8449 - July 19, 2015

Small tweaks to prior release.

Build 8429 - July 15, 2015

Followup release that fixes issues with opening up projects created in older versions of Stencyl.

Fix: Sample games / projects weren't opening up.
Fix: Getting null instead of normal blendmode when updating old games.
Fix: Can't save/compile game due to file access conflicts.
Fix: iAds - ad shows after it was hidden
Fix: Add 3x support to the engine
Fix: generic error dialog for android compilation errors
Fix: catch error if game format version cannot be parsed
Fix: trying to load OSX metadata file as an extension
Fix: behavior attributes resetting
Fix: catch engine compilation errors
Fix: error loading/saving maps
Fix: cannot upgrade kit made with earlier version (blendmode is null)
Fix: a preference from 3.3 causes uncaught exception when opening earlier version
Fix: wrong image dimension written when exporting actors (revert multi-row sprites)
Fix: Show warning if game cannot be written because destination file is in use
Fix: Rewrote our iAd support from scratch.
Fix: uncaught exception when opening game made with 3.3.1 in an earlier version
Fix: game doesn't open if actor has a missing sprite
Fix: exception on mobile page if no Xcode is installed

« Last Edit: July 19, 2015, 12:39:42 pm by Donni11 »


  • *
  • Posts: 4714
The most important changes between b8429 and b8449:

- [Fix] Controls not saved in behavior settings.
- [Fix] NPE when updating sprites before atlas manager is initialized.
- Added rectangle tool to Scene Designer.

Linux 32 bit:
- Fixed compilation issues on Linux 32 bit release.

- [Fix] NPE upon new game creation when xcode isn't detected on Mac.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)


  • Posts: 875
One thing annoying with stencyl 3 is that error when you are stuck  forever on something in the framework
and you get this error name
"Unexpected problem on thread AWT-EventQueue-0: java.lang.ArrayIndexOutOfBoundsException "

I think Justin or captaincomic know this problem*

I think i have found a solution to this
Not sure if it's fully work out

It's simple
When you open and you got this error many times
Close the engine , let it rest for some time and go back
Open it but do NOTHING , try to reach "Publish" box et publish your game (it's okay if it's unfinished , publish it for your computer)
Wait until it get published and try open your scenes afterwards
It worked for me after tried for an hour to get into it.

If it's really work i wonder why


  • *
  • Posts: 4714
That problem (assuming it's the one I'm thinking of) shouldn't happen if you use the .exe or the .bat that comes with the download. If you need more memory, just increase the amount in the .bat that's already there.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)


  • Posts: 875
I use my bat

here is the log

Maybe my number is a problem , i should increase more than 2500?

My computer is a laptop toshiba satellite 64 bits , windows 7 , quadcore
I'll probably have to change all of that .


  • *
  • Posts: 4714
Replace your .bat with this:

Code: [Select]
 -jar sw.jar
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)


  • Posts: 875
I tried twice with an old build of stencyl 3 and the last one (8453)
Seems working so far

Thanks a lot Justin !


  • *
  • Posts: 259
Hey, everyone! I haven't been on here for a while.

I've just noticed that Stencyl has been updated, again.

Just out of interest. Does this now allow you to enable Google Play Services without any save/load game errors?