Multitouch for Android not working

Shommey

  • Posts: 14
I'm pretty sure I've got everything right, but multitouch won't work for me. It's enabled in Settings, and I set block when multitouch start to print in console, but it prints nothing.. Also, I've checked that my device supports multitouch, and I've tried on 2 other devices. Nothing. Log:
2015-04-10 19:15:36,416 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.EditArea: Verifying Top Level... event-device-multitouch
2015-04-10 19:15:36,416 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: str-combine - true
2015-04-10 19:15:36,416 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: str-combine - true
2015-04-10 19:15:36,416 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: str-combine - true
2015-04-10 19:15:36,416 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: str-combine - true
2015-04-10 19:15:36,416 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: print - true
2015-04-10 19:15:36,417 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: if - false
2015-04-10 19:15:36,417 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: event-device-multitouch - false
2015-04-10 19:15:36,424 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.EditArea: Verifying Top Level... step
2015-04-10 19:15:36,424 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: step - false
2015-04-10 19:15:36,491 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.EditArea: Verifying Top Level... event-device-multitouch
2015-04-10 19:15:36,491 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: print - true
2015-04-10 19:15:36,492 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: if - false
2015-04-10 19:15:36,492 DEBUG [pool-1-thread-2] stencyl.sw.editors.snippet.designer.BlockField: Result for: event-device-multitouch - false
2015-04-10 19:15:38,243 DEBUG [AWT-EventQueue-0] stencyl.sw.app.doc.Workspace: Activated: Push Button
2015-04-10 19:15:38,254 DEBUG [pool-1-thread-2] stencyl.sw.app.tasks.OpenResourceTask: Open Took 2038ms
2015-04-10 19:15:38,410 DEBUG [AWT-EventQueue-0] stencyl.sw.app.tasks.OpenResourceTask: Total Took 2194ms
2015-04-10 19:15:55,144 WARN  [AWT-EventQueue-0] stencyl.sw.loc.LanguagePack: Missing: event.helper.mobile.multitouch.help
2015-04-10 19:15:59,104 DEBUG [AWT-EventQueue-0] stencyl.sw.app.App: Action: Test Game...

Also, I'm getting: WARN  [AWT-EventQueue-0] stencyl.sw.loc.LanguagePack: Missing: event.helper.mobile.multitouch.help


letmethink

  • *
  • Posts: 2545
Have you customised your behaviours to use multitouch?
~Letmethink

Shommey

  • Posts: 14
Yes, I did. After downloading Multitouch VirtualButton from StencylForge, which was pretty much same as my own behavior, it worked somehow. And later, after I disabled downloaded behavior and enabled mine, it works like a charm. I really don't know what's the problem was, but solved. :)

Max Finch

  • *
  • Posts: 2174
Yes, I did. After downloading Multitouch VirtualButton from StencylForge, which was pretty much same as my own behavior, it worked somehow. And later, after I disabled downloaded behavior and enabled mine, it works like a charm. I really don't know what's the problem was, but solved. :)

That's because that behavior is relying on mouse events right now, not multi touch.

What letmethink means is do you have this "Enable Multitouch" checked in your settings.