Issues with tiles: tileset scaling wrong and "phantom" collisions


  • Posts: 103

i am just working on a new project. my plan is to use the built-in tileset and create my levels using the scene editor. but i am experiencing some problems that keep me from doing so:

when i add tiles to my scene, everything looks good. but when running the game, the tiles are not shown correctly (too small, some look chopped off etc.). i am sure, that i set up everything 100% correct.
steps to reproduce: just make a new scene with all standard values, add a 32x32 tile (128x128 asset with 4x import) and observe.
there is already a thread for that, but no solution or answer yet (and it's in the wrong forum):,39639.msg229337.html#msg229337

2) when adding actors as ground tiles (i wanted to use tiles, but that does not work, see 1) to a scene using the scene editor, and iterating on the level design - i.e. moving around actors, deleting actors etc - sometimes some kind of "phantom collision" seems to stay in the level. i experience this with my little jnr project, where the runner always dies due to a collision with a tile-actor, that is not displayed there, in a specific level (i put in some debug code to check with what the runner is colliding when he is killed).
there also is a thread for that that is marked as solved, but in fact it is not really solved:,34187.msg194034.html#msg194034

my question is: are those bugs known? is there a workaround or something? is there a plan when this will be fixed? with those bugs, for me the scene editor/tileset features are not really usable... or am i the only one experiencing those issues!?


  • Posts: 5
I've the same.
When I import a tileset in 4x, then save and restart, the tiles are scalled and cutted.
In 1x, that's OK, but not for publishing.


  • Posts: 5
I have générated those log with projects that are not finished yet, but the problem is only graphic...


  • Posts: 103
thx for adding the screenshots and logs!

@stencyl team: any news here?


  • Posts: 1
I had the same problem. Maybe this will help

Adding a new Tile Set

   1   Design artwork at twice the size as normal for retina (eg. 64 x 64 if your game tile size is 32 x 32)
   2   Go to Game Center > Tilesets > Create New
   3   Import as Retina 2x and don’t worry about the grid lines dividing your tiles. This can be confusing. (Fig. 1 below). Your tiles won't be divided up.
   4   The tile size needs to be 32 x 32 on the import window (assuming this is the tile size you're using).
   5   After import, if it looks weird, like (Fig. 2 below) then you need to look at the Tile size (Fig 3 below)
 and correct it by clicking 'Change Tile Size and entering 32 x 32' (Or your target size)


  • Posts: 8
I believe I have found a workaround to the tiles importing incorrectly at 4x. When you initially create a new tileset, cancel out of the "import" window. then create a number of blank tiles in the editor - not sure if it matters how many rows/columns - I created the same number as what I needed imported. After that, click the "add tiles" button in the upper left above the tile editor, and import as you should (e.g. - 4x at 128x128 with a tile size of 32x32). This will place them in the editor looking normal. Now all you have to do is delete the unused rows/columns. Looks fine in a test run of my game as well.

Not a solution - but at least a working workaround!


  • Posts: 5
That's working for me.