[solved] Can't get Stencyl to find Java JDK


  • *
  • Posts: 2263
It's that time again.
Just re-installed my entire system, upgraded some pieces, took up another "big-ish" job, and then I cant export anything ...

I tried all different options, ranging from trying Java 6, till editing my Home Variables and installation paths (by default it's program files (x86), which I thought the space might have been a problem when I read about it). I ran about 12 exports or so an non of them worked. Logs are included and hopefully we can solve this issue quick again.

(i'm running build 8832 btw)

Just curious tho, why has this part always been so randomly an issue? On my previous setup (I only upgraded my GPU when it comes to my hardware upgrades) I installed everything without issues and it ran with the first try?

« Last Edit: November 30, 2015, 02:55:53 pm by TheIndieStation »


  • *
  • Posts: 2263
So today I somehow thought it might have solved itself, but unfortunately it didn't...

However I did found 2 interesting lines in the log viewer that might give an idea about whats going on.
When I clear the log and start compiling again, it says this somewhere in the beginning:

Found Java JDK at: C:\Program File\Java\jdk1.8.0_65

So even tho the exported log says it didn't find the JDK, the log viewer says it has found it.
But then right before the error pops-up, this appears:

[haxelib.exe] Caused by: java.io.FileNotFoundException: E:\Software\Stencyl Workspace\stencylworks\games-generated\TestGame\Export\android\bin\bin\classes.dex does not exist

And that's pretty much where my knowledge about these problems stops. Hopefully this sheds some light on the issue so we can fix this asap.



  • *
  • Posts: 2263
Another day trying to figure out what the heck is causing this issue...

So I came across an old answer I gave posted myself telling to downgrade to JDK 7, which I did. So the looking trough my latest log today, I came across 2 pieces of the log which are telling the exact opposite of each other:

2015-11-30 18:14:20,855 INFO  [AWT-EventQueue-0] stencyl.sw.io.write.resource.HXWriter: Building game with arguments: ANDROID, TESTING
2015-11-30 18:14:20,863 DEBUG [AWT-EventQueue-0] stencyl.sw.app.filewatcher.ExternalAppLauncher: E:\Software\Java\jdk1.7.0_79 looks like a valid JDK.
2015-11-30 18:14:20,863 INFO  [AWT-EventQueue-0] stencyl.sw.app.filewatcher.ExternalAppLauncher: Found Java JDK at: E:\Software\Java\jdk1.7.0_79

This is somewhere in the beginning of that log, while at the very end we still have this:

2015-11-30 18:14:39,542 INFO  [Thread-13] stencyl.sw.util.StreamGobbler: [haxelib.exe]        [dx] ERROR: No suitable Java found. In order to properly use the Android Developer
2015-11-30 18:14:39,542 INFO  [Thread-13] stencyl.sw.util.StreamGobbler: [haxelib.exe]        [dx] Tools, you need a suitable version of Java JDK installed on your system.
2015-11-30 18:14:39,542 INFO  [Thread-13] stencyl.sw.util.StreamGobbler: [haxelib.exe]        [dx] We recommend that you install the JDK version of JavaSE, available here:
2015-11-30 18:14:39,542 INFO  [Thread-13] stencyl.sw.util.StreamGobbler: [haxelib.exe]        [dx]   http://www.oracle.com/technetwork/java/javase/downloads

And something else that I still dont get is that I completely removed Java 8 (1.8.0), cleaned my register and installed Java 7, but still Stencyl tells I am using 8.

2015-11-30 18:14:04,732 INFO  [main] stencyl.sw.Session: Java Version: 1.8.0_60

So what am I missing here? The fact that it first says its all good, but then in the end again it isnt, is making this even more frustrating....

Logs below.


  • *
  • Posts: 2263
So appearently Stencyl does not like to be installed on any other drive then the C:/ drive...
I didnt even bother reinstalling java or re-adding those JAVA_HOME variables. Nope. Just uninstalled Stencyl from my E:/ drive reinstalled it on my C:/ drive, installed the SDK trough Stencyl itself and showed Stencyl where to find the JDK folder the exact same way as I did before, but now it works like a charm...

@Donni, that's probably your issue then as well.


  • Posts: 1
To Install the JDK Software and Set JAVA_HOME on a Windows System
Install the JDK software.

Go to http://java.sun.com/javase/downloads/index.jsp.

Select the appropriate JDK software and click Download.

The JDK software is installed on your computer, for example, at C:\Program Files\Java\jdk1.6.0_02. You can move the JDK software to another location if desired.


Right click My Computer and select Properties.

On the Advanced tab, select Environment Variables, and then edit JAVA_HOME to point to where the JDK software is located, for example, C:\Program Files\Java\jdk1.6.0_02.

If not JAVA_HOME , add one on User Variable , and value is: C:\Program Files\Java\jdk1.8.0_211