[Solved] Encountered Errors While Building Your Game - JDK Issue


  • Posts: 38
Hi all,

Apologies if I'm posting in the wrong spot (I'm new around here, and making my first simple game)... and of course, I already run into an issue...

• I'm on a Mac OSX 10.11.5 El Capitan
 • I have the latest JDK installed (I double-checked on oracle's site)
• I downloaded Stencyl 3.4.0 a few days ago for the first time, and have made one minor adjustment to the memory restriction (I kept getting that 90% memory error and increased the limit to 3GB - now it works nicely and runs faster). Other than that, it's out of the box new.
• I've made a rough prototype of a simple quiz game and I'd like to test how it ships out into the browser.

Ideally, I'd like to run this as a HTML5 game (I know it's experimental... but if it works in the few spots I need it to, then it will be a great experiment) but I can't even get it to publish -  I get an error. The preview looks pretty great, so I'm excited to see if the published result looks good and if it works on the browsers I need it to (it's for a tradeshow booth display - if it works on those tablets and computers it will work for my needs!).

Incidentally, this project for work also sparked an interest for me to start building my own doodle games - so I began making my first personal project as well. This is also experiencing the great preview/unable to publish issue.


PS - Log files and screenshots attached... any help is much appreciated!

« Last Edit: July 13, 2016, 09:40:42 am by LadyLala »


  • Posts: 1654
Hello LadyLala,

Welcome to the forum.

java -Dapple.awt.UIElement=true -jar /Applications/Stencyl-full/plaf/haxe/lib/lime/lime/templates/bin/compiler.jar --js "Export/html5/bin/Mini Monster Maker.js" --js_output_file /var/folders/8v/08f3h67s6vj0x9ls34dgnhmh0000gn/T//temp_13137379.js
2016-07-12 16:09:40,325 INFO  [Thread-15] stencyl.sw.util.StreamGobbler: [haxelib] No Java runtime present, requesting install.

It appears that the java runtime can't be found. Try using the Stencyl method of installing the JDK :  Debug -> Android -> Reinstall java JDK  (I know it says Android)

Also please try to make a habit of creating your projects without spaces (really without any special characters: use the alphabet)
Proud member of the League of Idiotic Stencylers! Doing things in Stencyl that probably shouldn't be done.


  • Posts: 194
Seems like it can't find JRE in the system. You probably do not have it installed.
Stencyl actually comes with it (it runs independently), but it only works with Stencyl.
If other third party component trying to run its jar file, it might try to locate the JRE from the system instead.

JDK and JRE is two totally different thing.

JDK = Java Development Kit (for Android and other Java app creation)
JRE = Java Runtime Environment (to run Stencyl and other Java apps)

Try installing JRE.
You need it, in order for it to run that "compiler.jar" file.

Side note :
JDK is actually not needed at all. Unless you want to build for Android. Everything will run just fine without it.


  • Posts: 38
Aha, it seems my JDK was corrupted or something was wrong with it - when I tried M.E.'s method of reinstalling via Stencyl, it solved my issue.

Now I'm able to publish my horrid first games! Wohoo! Thanks everyone for the assistance.

Also, thanks for the tips about naming conventions - even though these are just prototypes, you're right, I should get in good habits.


  • Posts: 1