Updated to iOS 10 and Xcode 8 - now game gets error - log attached

btg

  • Posts: 124
After updating my phone and my mac with the latest updates, I tried to test my game and get an error.  Anyone run into this and have any idea what I need to do? Error regarding "Check Dependencies."

Thanks!
chainreactiongames.org
Get "Phose" FREE on Android and Apple devices :)

Justin

  • *
  • Posts: 4712
Xcode 8 requires the latest build of Stencyl. Grab that and set your Team ID.

http://community.stencyl.com/index.php/index.php?topic=49215.msg272925#msg272925
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

btg

  • Posts: 124
Xcode 8 requires the latest build of Stencyl. Grab that and set your Team ID.

http://community.stencyl.com/index.php/index.php?topic=49215.msg272925#msg272925
I installed the latest build, followed your instructions, ran clean project, and am now getting a new error.Level:     INFO
When:      2016-09-23 17:47:08:306
From:      stencyl.sw.util.StreamGobbler

[haxelib] [  0%] Looking up developer disk imageLevel:     INFO
When:      2016-09-23 17:47:08:306
From:      stencyl.sw.util.StreamGobbler

[haxelib] [ !! ] Unable to mount developer disk image. (e80000e2)
chainreactiongames.org
Get "Phose" FREE on Android and Apple devices :)

Justin

  • *
  • Posts: 4712
Could you post your full logs or a larger portion of the surrounding log? Thanks.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

Justin

  • *
  • Posts: 4712
Never mind, this might be the issue.

http://stackoverflow.com/a/33460470

What device are you trying to test on? Xcode 8 only supports iOS 8.0 through 10.0 by default.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

btg

  • Posts: 124
Never mind, this might be the issue.

http://stackoverflow.com/a/33460470

What device are you trying to test on? Xcode 8 only supports iOS 8.0 through 10.0 by default.
iPhone 6s running iOS 10
chainreactiongames.org
Get "Phose" FREE on Android and Apple devices :)

Max Finch

  • *
  • Posts: 2174
And the latest xcode 8?

btg

  • Posts: 124
Yes - Xcode 8 - that is when the error started showing up - When I updated to ios 10 and xcode 8...  I am testing on an iPhone 6s with iOS 10.

« Last Edit: September 26, 2016, 12:02:29 pm by btg »
chainreactiongames.org
Get "Phose" FREE on Android and Apple devices :)

ciprianz

  • Posts: 16
Hi,

Did you manage to fix this issue? I have the same issue.

Best regards,
Ciprian Zegrean

colburt187

  • *
  • Posts: 2416
Hi,

Did you manage to fix this issue? I have the same issue.

Best regards,
Ciprian Zegrean

Whats your error, can you attach your logs?


ciprianz

  • Posts: 16
Thank you TheIndieStation !

I did reinstall everything and everything works fine now.

Best regards,
Ciprian Zegrean

manaskk

  • Posts: 153
updated OS to : MacOS Sierra 10.12.1
xcode : Version 8.1 (8B62)
stencyl: 9280

* inserted Team ID -> IOS team ID slot in settings
 * opened project in xcode -> build setting -> development team : "selected to my name"

and i still get :

Code signing is required for product type 'Application' in SDK 'iOS 10.1'
error: [haxelib] Signing for "project" requires a development team. Select a development team in the project editor.
[haxelib] Check dependencies


tried reinstalling xcode and stencyl as suggested by "ciprianz" above.
please help been stuck on this for days.

stefan

  • *
  • Posts: 2263
Run > clean project

manaskk

  • Posts: 153
thx indiestation for the reply...i just did that more than 2 times.. still having the same error :(