3.4 beta 4 Update issue

thedragonllama

  • Posts: 33
Upon updating to 3.4 beta 4 I encounter the following error when attempting to activate a dialog ingame:

Code: [Select]
ArgumentError: Error #2015: Invalid BitmapData.
at flash.display::BitmapData/ctor()
at flash.display::BitmapData()
at dialog.util::BitmapDataUtil$/getPartial()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/util/BitmapDataUtil.hx:122]
at dialog.util::BitmapDataUtil$/getScaledPartial()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/util/BitmapDataUtil.hx:178]
at dialog.util::BitmapDataUtil$/get9Scaled()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/util/BitmapDataUtil.hx:84]
at dialog.core::ScalingImage/setSize()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/core/ScalingImage.hx:40]
at dialog.core::DialogWindow()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/core/DialogWindow.hx:48]
at MethodInfo-5780()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/ext/DialogBase.hx:77]
at dialog.core::DialogBox/runCallbacks()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/core/DialogBox.hx:652]
at dialog.core::DialogBox/beginDialog()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/core/DialogBox.hx:267]
at dialog.core::Dialog$/cbCall()[/Users/andrewsantos/Desktop/stencylworks/engine-extensions/com.polydes.dialog/src/dialog/core/Dialog.hx:126]
at MethodInfo-9439()[Source/scripts/Design_278_278_Dialog.hx:105]
at com.stencyl.models::Actor/innerUpdate()[/Users/andrewsantos/Downloads/Stencyl-full/plaf/haxe/lib/stencyl/1,00/com/stencyl/models/Actor.hx:1512]
at com.stencyl::Engine/update()[/Users/andrewsantos/Downloads/Stencyl-full/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2478]
at com.stencyl::Engine/postUpdate()[/Users/andrewsantos/Downloads/Stencyl-full/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2617]
at com.stencyl::Engine/onUpdate()[/Users/andrewsantos/Downloads/Stencyl-full/plaf/haxe/lib/stencyl/1,00/com/stencyl/Engine.hx:2610]

At certain scaling sizes it seemed to work a few times, but now I can't seem to even get that. Help is greatly appreciated.

« Last Edit: September 30, 2016, 03:02:46 am by Justin »