Events for actor do not work [SOLVED]

doccharlie

  • Posts: 11
Hello. I am trying to add an event that moves the character to my command, attached bellow, but it doesn't work. Beneath the event is another set of commands which I previously attached to the main loop to test it and see if it worked. What it should have done is made the actor jump around the screen randomly (in the x axis) to prove to me that the event works. However it did not.
I hope you can help me figure out what the problem is. Thanks

« Last Edit: April 29, 2017, 07:26:30 am by doccharlie »
Love to learn new things and am really open to suggestions :)

KramerGames

  • Posts: 405
I'm not sure, but did you try to change "was pressed" to "is down"?

About the loop at the bottom: It is all triggered at the same time (10 times after one second), you should use a "do every 1 seconds" block under flow--> time
Parasites United  (Idle Parasite Game)

doccharlie

  • Posts: 11
I'm not sure, but did you try to change "was pressed" to "is down"?

About the loop at the bottom: It is all triggered at the same time (10 times after one second), you should use a "do every 1 seconds" block under flow--> time

Thanks for your response and I apologise for my ambiguous question. I've solved it. I've discovered that it was in fact in the physics that I set the actor. I set it to 'minimal' under actor mode, and I also did not specify correctly what the actor could collide with, as I was using another actor in the background.
Love to learn new things and am really open to suggestions :)