Encountered errors - Running game on Android

vikingpotato

  • Posts: 852
My mobile project has suddenly died.
I can play it on flash, but every time I try to run it on mobile(android device), the build fails.
- I have tried to clean my project, restart Stencyl, Tried to make sense of the logs, ..don't know what to do.
- The project ran perfectly the last time I ran it, all I have changed is added some more behaviours that use the drag and drop UI, and downloaded a very basic behaviour from the forge.

It seems to me like one the usual Stencyl mood swings to me that ruin work and motivation.
Could someone point me in the right direction?

« Last Edit: August 03, 2017, 04:30:45 pm by vikingpotato »

vikingpotato

  • Posts: 852
Also I am using the latest 3.4 public build for development. Anyone?
<ATTACHED A SCREENSHOT TO MOTIAVTE PEOPLE TO HELP :)>

« Last Edit: August 03, 2017, 04:38:13 pm by vikingpotato »

vikingpotato

  • Posts: 852
I was looking for threads where people were able to address this fairly common situation. I didn't see a single answered post on the entire first page of search results.  I guess this error is just the death of the project by an act of God, or something.

rob1221

  • *
  • Posts: 9471
There doesn't seem to be any details in the log about the error, which makes it hard to help.

vikingpotato

  • Posts: 852
I cleaned the game, cleared the logs and chose 'Run App in Debug Mode (Android)' from the top menu.
Maybe this helps generate more informative logs.

Luyren

  • *
  • Posts: 2731
- The project ran perfectly the last time I ran it, all I have changed is added some more behaviours that use the drag and drop UI, and downloaded a very basic behaviour from the forge.
Shot in the dark here, but have you tried a version of your game without these additions?
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.
Twitter

stefan

  • *
  • Posts: 2263
Save your project under a second name and start disabling extensions and removing behaviors. It is a bit of a rough approuch but it will get you to your source as fast as possible.

I do recall something about reinstalling Stencyl as well. Have you tried that?

vikingpotato

  • Posts: 852
@Luyren Yes I have it, but I don't want to roll back 6 hours of development I did since the last stable version.

@TheIndieStation I am using a mac, didn't really install it. I tried running Stencyl from a fresh copy though. I think this way I can track the problem, but there is no guarantee this won't happen again even after all this effort disabling and testing each module; generating one mobile build takes forever.

I am going to take a break from working on Stencyl for a few month till I hear about a new less buggy version. I just bought the license for another famous game engine, and I use this time to try and get as adept with it as I am with Stencyl.

stefan

  • *
  • Posts: 2263
A project never suddenly dies. You either installed a new profram that interferes with Stencyl, or perhapa you closes stencyl when it was still saving. In all my years of using stencyl I have never encountered such problems, which is the reason I always seperate ny work from personal activities. Didnt you have any backups?

Perhals you can send me your backup file to see if I can open it without any problems.

vikingpotato

  • Posts: 852
Okay I can send you a backup.
The project isn't dead, it works on web and html5, I can work on it like before. It is not able to generate any mobile builds any more, I get the aforementioned error every time. Is it something you ever encountered in the past?

stefan

  • *
  • Posts: 2263
Nothing that sudden no. The times I did get the error, it was because I added something that I wasnt supposed to. Funny thing is, you can get error by the most simple issues. For example, if you try to run a game in flash, while you have any block related to admob in your code, it will result in an error. I just notices you used 2 premade behaviors, one which is from the forge. You are aware that people can no longer upload to the forge, and there is a big chance that the behavior might have outdated underlying code in there?

Have you tried removing those 2 latest behaviors?