For each touch point errors [1.3.2]

8bitwit

  • *
  • Posts: 93
I'm getting compiler errors for each touch point again.

The following build commands failed:
   CompileC Build/AppScaffold.build/Debug-iphonesimulator/AppScaffold.build/Objects-normal/i386/Design_26_26_eachtouchpoint.o Classes/Design_26_26_eachtouchpoint.mm normal i386 objective-c++ com.apple.compilers.llvmgcc42
(1 failure)

I can email a copy of the game if you need it, but right now I'm going to sleep. I have to be to work in 4 hours!

« Last Edit: December 10, 2011, 01:10:56 pm by Jon »

8bitwit

  • *
  • Posts: 93
I've tested "for each touch point" in other example games and I'm getting the same error.

8bitwit

  • *
  • Posts: 93
Any ideas on what could be causing this? My game has pretty much hit a brick wall until this is resolved again.

Jon

  • *
  • Posts: 17533
Is this a regression or something new?

8bitwit

  • *
  • Posts: 93
A regression I believe, I didn't change anything in the behavior when I moved to 1.3

Jon

  • *
  • Posts: 17533
That's odd - it should be identical to what I sent you earlier. The binaries even have a timestamp dating back to Nov 29th, which is the same day I sent you the binaries.

Could I get a screenshot of all of xcode. Does it say anything more about the error or what line it affects?

8bitwit

  • *
  • Posts: 93
Here are a couple of screen shots of the errors

Jon

  • *
  • Posts: 17533
Go plaf/ios/template/base/headers/Game.h

Replace this (line 577)
@property (nonatomic, assign) NSArray* moveTouches;

With this
@property (nonatomic, assign) NSArray* dragTouches;

Looks like I didn't update the headers for the release build.

8bitwit

  • *
  • Posts: 93
That did it, thank you!