Newest Xcode version seems to have broken Stencyl?

Kottis

  • Posts: 60
I am using the latest 3.4 version of Stencyl, and after updating to Xcode 10.0 yesterday I get an error saying #include <typeinfo> and [haxelib] /Applications/Stencyl/plaf/haxe/lib/hxcpp/hxcpp/include/hxcpp.h:17:13: fatal error: 'typeinfo' file not found when compiling for Mac. Tried Cppia as well, that runs for a while but crashes consistently at certain points – unsure what exactly is causing it to crash.

I have been thinking about upgrading for a while, so would just like to know if this is working in the latest version?

designpeg

  • *
  • Posts: 731
I've got 3.5 and the latest version of xcode (for IOS 12) and it works for me. My biggest issue with using 3.5 is that a loading bar screen pops up for a split second between the launch screen and the first scene loading - hopefully that will be fixed before I release my game - as it looks really sloppy on a published app.

FMStudioGameDev

  • *
  • Posts: 230
I've got 3.5 and the latest version of xcode (for IOS 12) and it works for me. My biggest issue with using 3.5 is that a loading bar screen pops up for a split second between the launch screen and the first scene loading - hopefully that will be fixed before I release my game - as it looks really sloppy on a published app.
Have you tried the latest build? It seems that this should be fixed (I didn't have the chance to test yet)

designpeg

  • *
  • Posts: 731
Cool, I'll try it tonight.

Kottis

  • Posts: 60
Ok, I’ll try upgrading then, thanks!

designpeg

  • *
  • Posts: 731
just tried b9990 and I have the same problem - app starts up, then black screen.

zerosimms

  • Posts: 710
just tried b9990 and I have the same problem - app starts up, then black screen.
Me too, I tried two different games to be sure, right in the process of trying to debug:(

zerosimms

  • Posts: 710
Not having much luck with debugging, can't get anything to show up in 'Game Controller',  Xcode  or anything useful in Log Viewer and to make matters worse, I've just redeployed the game to my Android device and now that's failing to launch...

I could really do with some help here... I've spent 3 hours on it and got nowhere :(

Running Stencyl 3.5.0
Xcode 10.0



Justin

  • *
  • Posts: 4645
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

zerosimms

  • Posts: 710
Downloading it now and will report back shortly :)

zerosimms

  • Posts: 710
Yup - Thank you Justin, Build b9991 has resolved the black screen issue :)

Crovaxus17

  • Posts: 76
I have been having the same problem mentioned at the start of this thread:
I am using the latest 3.4 version of Stencyl, and after updating to Xcode 10.0 yesterday I get an error saying #include <typeinfo> and [haxelib] /Applications/Stencyl/plaf/haxe/lib/hxcpp/hxcpp/include/hxcpp.h:17:13: fatal error: 'typeinfo' file not found when compiling for Mac. Tried Cppia as well, that runs for a while but crashes consistently at certain points – unsure what exactly is causing it to crash.

I get the exact same error message in my logs. But I do not have 3.5, and at the moment it is not really economical for me to upgrade just to get access to the beta (I was hoping to put it off until later in my game's development). Is there any way to fix this issue with Stencyl 3.4 and Xcode10? (I am using OSX 10.14 Mojave, if that is significant....)

Kottis

  • Posts: 60
I don’t have any new info regarding this but I would not recommend upgrading. I did and although this issue seems to be fixed, I experienced another program-breaking bug. Maybe it only affects some users, since there aren’t a lot of bug reports, so you could try and roll the dice I suppose. I requested a refund a few days ago, so it is also possible it has been fixed in the latest versions, but I haven’t seen any updates about it from the dev team so far.

Crovaxus17

  • Posts: 76
Okay. Thanks for the info. I hope it works out for you, and that they work out these bugs.