Error w/ curriculum project files


  • Posts: 2
I have downloaded Stencyl and the education kit provided by Stencyl. Project1 worked just fine, but all other projects won't compile. When we try to compile any of the other projects, we get the following error:
An ActionScript error has occured:
[lime.utils.Assets] ERROR: There is no IMAGE asset with an ID of "assets/graphics/3x/tileset-31.png"
   at lime.utils::Log$/error()
   at lime.utils::Assets$/getAsset()
   at lime.utils::Assets$/getImage()
   at openfl.utils::Assets$/getBitmapData()
   at com.stencyl.utils::Assets$/getBitmapData()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\utils\Assets.hx:28]
   at com.stencyl.models.scene::Tileset/loadGraphics()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\models\scene\Tileset.hx:138]
   at[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\io\TilesetReader.hx:49]
   at com.stencyl::Data/readResource()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Data.hx:272]
   at com.stencyl::Data/loadResourceFromMbs()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Data.hx:216]
   at com.stencyl.utils::LazyIntMap/get()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\utils\LazyIntMap.hx:51]
   at com.stencyl.models::Scene/readRawLayer()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\models\Scene.hx:553]
   at com.stencyl.models::Scene/readRawLayers()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\models\Scene.hx:510]
   at com.stencyl.models::Scene/load()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\models\Scene.hx:143]
   at com.stencyl::Engine/loadScene()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Engine.hx:996]
   at com.stencyl::Engine/begin()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Engine.hx:944]
   at com.stencyl::Engine()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\com\stencyl\Engine.hx:733]
   at Universal/preloaderComplete()[C:\Program Files (x86)\Stencyl\plaf\haxe\lib\stencyl\1,00\Universal.hx:408]
   at scripts::StencylPreloader/unload()[C:\Users\cmoulder\AppData\Roaming\Stencyl\stencylworks\games-generated\project2\Source\scripts\StencylPreloader.hx:340]
   at scripts::StencylPreloader/onLoaded()[C:\Users\cmoulder\AppData\Roaming\Stencyl\stencylworks\games-generated\project2\Source\scripts\StencylPreloader.hx:309]
   at lime.utils::Preloader/start()
   at lime.utils::Preloader/updateProgress()
   at lime.utils::Preloader/current_onEnter()

I'm not sure where to go from here. I've uninstalled and reinstalled the program and tried again with a new set of projects. We just continue to get the error. It's interesting that Project 1 works just fine, but everything else has been an issue. Any help would be appreciated.


  • *
  • Posts: 2791
[lime.utils.Assets] ERROR: There is no IMAGE asset with an ID of "assets/graphics/3x/tileset-31.png"
Someone more knowledgeable please chime in if I'm mistaken.
It appears you have a resource that doesn't have an associated image, and it looks like it's a tileset. It could be the 3x scale version (Settings > Advanced, you can check the scales you want in your game). I think you can either delete that tileset, or uncheck the 3x scale and clean your project (Tools > Game > Clean Project and Clean Up Unused Files), or just clean the project without changing the the scale options.
My Stencyl resources are available here:
Cutscenes, RPG Elements, Particles, Map System and many more.


  • Posts: 2
Interestingly, the 3x scale was already unchecked. I enabled 3x scale and tested. The game complied just fine. It looks like 3x scale is unchecked for several of the projects by default. As soon as I checked them, closed the project, and reopened them, they had no issues. Thank you for the response and helping me sort through this issue. I very much appreciate it!