Behaviors don't work.


  • Posts: 1
Hey, i'm making my first game in stencyl, a platformer. I have been trying to use the "Jump and Run" behavior that came with stencyl. It did nothing. So I use the "Platformer Movement" resource pack behaviors. That also did nothing. So my not very big brain decides to make it all by himself and then realized he wasn't smart enough to do it, followed the guide, got more confused and is making a forum post now.  :-\


  • *
  • Posts: 2747
It did nothing.
What do you mean by that: do you press the keys and nothing happens? What are the physics settings for your actor? Is it set to cannot move? Do you have any code in its events tab that's preventing its movement? If you remove all behaviors and just use the "jump and run movement" behavior, can you get your actor to move?
My Stencyl resources are available here:
Cutscenes, RPG Elements, Particles, Map System and many more.


  • Posts: 47
I usually use that prepackaged code only to get ideas and learn stuff. Once I've done that, I strip it to what makes sense for me or start over with my own. It's your first game, try not to get disappointed. Even though Stencyl makes it pretty easy, it still takes a lot of learning. (Check out my signature.) The biggest help for me is doing the tutorial games. I usually don't want to, but I'm always glad I did. It costs much less time in the long run. Good luck.

PS. it also helps to make a smaller test game using only what you are trying to learn.
Tonight I'll make a game like Skyrim or Call of Duty. It'll be called Delusional.


  • Posts: 51
I have also encountered this problem when importing behaviours from stencylforce to the newest build of stencyl. 4.0.2
Just try to edit/open each behaviour before attaching in to an actor, save, and then attach the behaviour to actor.
Another problem that I encountered was that when I have opened a behaviour it actually showed nothing inside, no blocks of code, nothing, I believe this is a bug of the newest stencyl build, when it comes to use old behaviours from stencylforge.

in order to solve this you should use an older version of stencyl to check and see the code inside behaviours export it and import it to stencyl 4.0.2


  • Posts: 251
This probably won't solve every issue but the on-ground and air jump behaviors are unnecessary since the jump and run takes care of all of that. Also, if you haven't already, go through the crash course.


  • Posts: 3
I agree, there seems to be some sort of issue upgrading the sample projects to the latest build. The platformer loaded but no controls worked. Camera following doesn't work, and neither do any of the actor controls. Recreating these as events tied to the actor worked.