Actors appear as white boxes on Windows and HTML5


  • Posts: 31

I am trying to test my game. I ran it on Flash (Player), Android, HTML5 and Windows.
I also posted this on the Bugs subforum, in case it is a bug.

The game works fine on Flash (Player) and Android.
But on Windows and HTML5, there is a bug with actors. Some actors appear as white squares.

Here is what the game looks like in Flash (good):

Here is what the game looks like on Windows (glitched):

What is even stranger is that this seems to be a problem only on certain animations of the actors. Here's what I mean:

In this screenshot, the white box actor is the same actor as the guard with the torch, just different animations:

Note: All my assets are bound to the Main Atlas. This is my only Atlas.
Note: My Stencyl version is 4.0.4.

What I tried:
- I tried to enable/disable all atlases for all scenes.
- I tried to have the Main Atlas bound to all scenes.
- I tried to have the Main Atlas bound only to that scene in the screenshot.
- I cleaned up the project
- I checked the resources folder in the game folder and it looks fine. The assets folder in the games-generated folder in the windows folder also looks fine (for all sizes, e.g. x1, x1.5, x2, etc, the sprites seem to be there).
- I reinstalled Stencyl (latest version)

I don't know what else to try and I am starting to panic since I have been working on this project for months.

If anyone knows how to fix this or what might be the problem, I would really appreciate it, as it is a gamebreaking thing I don't know how to fix :(. I hope it's not a bug.

Thank you!


  • *
  • Posts: 2718
Whenever I saw something like that, it usually meant Stencyl's running out of memory when trying to load the actor's sprite, or something to that effect, assuming there's no other code affecting your actors or some shenaniganes with the image API. I am not 100% sure this is the cause though.
You can try breaking your game into multiple atlases.
You can try going to Settings > Settings > Advanced, and removing all scales (the x1.5, x2, x3 and x4). Then go to Tools > Game > Clean Project and Cleanup Unused Files, restart Stencyl and see if it makes a difference.
And you can also ask on the Discord server, it's more active in there.
My Stencyl resources are available here:
Cutscenes, RPG Elements, Particles, Map System and many more.


  • Posts: 31

Thank you for the reply and sorry for the late answer. I posted this on bugs as well and I updated my post there, forgot to update here.
I managed to fix it. I had a code block with an empty slot (I even had a red warning on it). After I removed it, it worked.

It's weird though that the game has been working perfectly fine until then. That' block had been there for months lol, and Stencyl never complained.

Anyway, I am glad I managed to fix it!