First three tiles at the Back of the scene don't register collisions.

Chatran

  • Posts: 6
When I make a scene the Player Actor would freeze if they went to the back of the screen so I made them always active which fix that but now if a bullet is shot at an enemy (which is still active) at the back of the screen the collision won't register. Could someone please help me with this.

Luyren

  • *
  • Posts: 2703
I'll assume you meant "off-screen" instead of back of the screen.
If your actors are off-screen, they need to be set to always active. That goes for your bullet as well. You didn't specify if your bullet was set to always active or not.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.
Twitter

Chatran

  • Posts: 6
The actors are on screen (by back of screen I meant the first three tile columns in a scene I think this could be a bug) and are both set to active on screen I tried set to enemy actors to active always which fixed the collision detection (switching the player's bullets to active always didn't do anything)  but I like to have them set to active on screen to make the game run better.
This video should help.

Sorry, I'm not very good at describing these things but thanks for helping Luyren.

Luyren

  • *
  • Posts: 2703
I cannot reproduce that on my end, so this is likely some thing on your bullet code.

Your message was a bit confusing: you set your enemy to always active, and mentioned it fixed the "collision detection". So is the issue on the video fixed or not?

And by the number of bullets in that video, setting them to always active won't hinder performance, and either killing them off-screen or after a certain time has passed since creation will prevent any possible performance drops.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.
Twitter

Chatran

  • Posts: 6
Sorry about the confusing message, I wrote it late last night.

But ya the video was takin with the enemy set to Active on Screen, so I will just set the enemy to Active Always which did fix it I was just worried it slow down the game but like you said it won't, so I'll just do that.

This is a weird glitch that happens to my all actors every time a make a game, so I don't know what's going on and nobody else seems to be having this problem but this fixed it.

Thank you so much, I really appreciate you taking the time to help me with this.   

Luyren

  • *
  • Posts: 2703
Consider using this block to increase the off screen bounds.
If you said you had issues with the first three tiles from the camera, consider increasing the off screen bounds by the size of three tiles.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.
Twitter

Chatran

  • Posts: 6
Yes! that block worked great I've got no more problems with actor collisions!

Thank you again Luyren this helped me a lot.