[Solved] Stencyl can't find installed Xcode

makaydenko

  • *
  • Posts: 32
After select iOS Device and click on the "Test Game" button I get Error window:

Xcode 9 or greater required.
The currently active Xcode install is version 0.0. Update Xcode to build your game.

But I have installed Xcode 13.2 + Command Line Tools.
Please help.

« Last Edit: February 10, 2022, 11:20:36 pm by makaydenko »

Justin

  • *
  • Posts: 4645
Sorry, this is a problem in the current public release of Stencyl when Xcode uses a 3-part version number (x.y.z instead of x.y).

If you'd like to subscribe to Stencyl, you can access the private betas in which that bug is fixed, or you can wait for the next public release of Stencyl, and in the meantime, use a version of Xcode that has a 2-part version number (13.0, 13.1, 13.2, etc).
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

makaydenko

  • *
  • Posts: 32

makaydenko

  • *
  • Posts: 32
What is the maximum version of Xcode supported? If I use Xcode 13.3 then I get error "Invalid Toolchain. Your app was built an unsupported SDK or version Xcode".

Justin

  • *
  • Posts: 4645
I've never seen that error before. Upon searching for it with Google, the first result is this.

https://developer.apple.com/forums/thread/125552

This error includes significantly more information. Is it possible that yours included some more information as well?

From that error, it appears it may be caused by using a version of Xcode that some of Apple's dev tooling doesn't yet support. Since Xcode 13.3 is still in beta, that sounds like it's possible.

To answer your question about which versions of Xcode Stencyl supports, it should support all the latest versions, and if you ever find anything wrong, let me know and I can fix it. This, on the other hand, appears not to be an issue with Stencyl, but that a version of Xcode is being used that isn't supported by all of Apple's tools. If my take from reading that thread is correct, anyway.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

makaydenko

  • *
  • Posts: 32
Thanks! I installed Xcode 13.0. Now this error is gone.

Most likely, the beta version of Xcode is better not to use yet.