[SOLVED] Compile issue

badower

  • Posts: 22
I modified the sample game 'Alien Approach' to have the Aliens fade in and out, and have Luyren's Particles behaviour emit particles from the Aliens - all works OK when compiled with Flash player.

But when compiled for Windows and Android, the game runs without any of those changes happening.
Weird.
Any ideas please?

I really like Stencyl and after trying most other game engines, I want to focus on Stencyl and learn it well.
But this appears to be a show stopper for me.

« Last Edit: September 10, 2022, 08:20:39 pm by badower »

merrak

  • *
  • Posts: 2724
Any unusual messages in the log viewer?

badower

  • Posts: 22
Thanks for your reply, but no, there are no error messages - compile goes straight thru to the end and builds the .exe

merrak

  • *
  • Posts: 2724
I've never heard of this happening before. My best guess is some kind of Windows related issue. Unfortunately, since I don't use Windows much, I can't think of where to go from here. If you don't hear back from anyone here, try asking on the Discord server. If there is a bug in Stencyl itself, Justin would need to fix it--but if it's a Windows issue, someone else may have a suggestion.

Luyren

  • *
  • Posts: 2740
Tools > Game > Clean Project. See if that changes anything.
You can also put print blocks in your code and see if they show up in the log viewer/game controller during gameplay, to confirm your changes are being applied.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.
Twitter

badower

  • Posts: 22
I tried Luyren's suggestion to clean out the cache, but to no avail.

After the clean, I Immediately did a Windows compile which didn't change anything.
I then re-compiled with the Flash player and it works perfectly,
with the Aliens fading in and out, and Luyren's particles going off every few seconds as I  programmed it to do,
but the Windows (and Android) compiles run the game but without these 2 features at all.

Given no one else has this issue, it must be something local on my Windows 10 laptop.

I don't think I have a virus because I have Norton's running in the background and it has never let me down for last 10 years.

Thanks for your responses - really appreciated.

Justin

  • *
  • Posts: 4663
I don't think this should affect it, but I can't think of anything else: disable the hxcpp compile cache and try again. You can find it at Tools > HXCPP Compile Cache Settings in the menu.
For Live Support: Join our discord server and ping me @justin.
I'm most often available between 10am and 10pm Japan time. (GMT+9)

badower

  • Posts: 22
This is already NOT enabled.

I just tried an HTML compile, and it half works.
i.e. the Aliens don't fade in and out BUT Luyren's particles spawn every few seconds just as they are programmed to do
(but that doesn't happen with a Windows compile).

This is very strange, and although I see it, I still find it difficult to believe!

badower

  • Posts: 22
I uninstalled Stencyl, downloaded and installed it again, and now the same game in a Windows compile works perfectly.

I had done this previously but it made no difference.

However, this time there is that little icon 'Game Controller' which I'm almost certain wasn't there before.

Thanks everyone for your feedback.