Trying to fade my logo in but I got an error

HidetoKoudanshi

  • Posts: 127
I'm sure I'm doing this wrong, so can someone help me understand my mistake? I'm trying to create a loading screen (scene) that fades my logo in, then out in a switch to the scene where my actual app code is.
If I ever commission you for code work, please know that I understand how commissioning works. You must get paid first before you will code anything for me. Only once you are paid the agreed-upon price, will you begin coding for me. I respect artists and coders. You deserve to be paid for your hard efforts.

Luyren

  • *
  • Posts: 2782
Your "TextInput" behavior has the parameter "sceneID" without any value. You probably forgot to set a scene to switch to in a scene switch block.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.

HidetoKoudanshi

  • Posts: 127
No, there's a Scene selected in the "Switch to" block called "Choose Pod Type".
If I ever commission you for code work, please know that I understand how commissioning works. You must get paid first before you will code anything for me. Only once you are paid the agreed-upon price, will you begin coding for me. I respect artists and coders. You deserve to be paid for your hard efforts.

Luyren

  • *
  • Posts: 2782
You can click the error message and select "open all", it will point to where the error is.
My Stencyl resources are available here: https://luyren.itch.io/
Cutscenes, RPG Elements, Particles, Map System and many more.

HidetoKoudanshi

  • Posts: 127
I'm a derp. Thanks so much! That fixed it. Rogue code I deleted.
If I ever commission you for code work, please know that I understand how commissioning works. You must get paid first before you will code anything for me. Only once you are paid the agreed-upon price, will you begin coding for me. I respect artists and coders. You deserve to be paid for your hard efforts.

HidetoKoudanshi

  • Posts: 127
Solved the error but now I can't get the logo to fade in. I made it into an Actor and can fade it out but fading it in isn't working.I've tried Scene Event > When Created > Create Actor >Fade in Last created actor and I've tried placing the actor already in the scene and then fading that in.

What's the best way to fade this in, then out?
If I ever commission you for code work, please know that I understand how commissioning works. You must get paid first before you will code anything for me. Only once you are paid the agreed-upon price, will you begin coding for me. I respect artists and coders. You deserve to be paid for your hard efforts.

HidetoKoudanshi

  • Posts: 127
Answering myself! I didn't know you had to set the actor's initial opacity to 0%! Did that and it works perfectly!
If I ever commission you for code work, please know that I understand how commissioning works. You must get paid first before you will code anything for me. Only once you are paid the agreed-upon price, will you begin coding for me. I respect artists and coders. You deserve to be paid for your hard efforts.