Bug Issue: Shaders crashing game on Windows


Pages: 1

Luyren

  • Master Stencyler
  • *
April 05, 2024, 03:40:14 pm
b12205, on Windows

When testing game for Windows desktop target, if I use the "apply shader" to game, it crashes (closes) without any error message. Nothing is displayed on the game controller either. Oddly enough, the sample game has a "print [a]" followed by the "apply shader", but even the print is not showing up.

Sample game attached along with the logs (all in the .rar file). Press up to print "a" and apply a shader (tint screen to yello at 100%), press down to reload the scene. I was originally checking a report that changing scenes when a shader is in action was crashing the game, but seems the issue was the shader itself.


New attachment added by Luyren - April 05, 2024, 03:40:39 pm


Luyren

  • Master Stencyler
  • *
April 12, 2024, 02:16:05 pm
This probably is not related to the initial issue, but I'll add it here just in case:
I was messing with "import openfl.filters.ShaderFilter;" and tried to apply a shader to an actor as an actor effect, see if I could get lucky with it. I used "new ShaderFilter(new BloomShader())" in a code block as the effect.

I got a compile error that reads "com.stencyl.graphics.shaders.BloomShader should be openfl.display.Shader".

And to be clear, the original issue is an error at runtime. This one is happening on compile.
« Last Edit: April 12, 2024, 02:16:57 pm by Luyren »


Pages: 1

Details

  • Reported
    April 05, 2024, 03:40:14 pm
  • Updated
    April 16, 2024, 07:04:07 am

  • View Status
    Public
  • Type
    Bug
  • Status
    New
  • Priority
    Normal
  • Version
    3.5.0 beta 1
  • Fixed in
    (none)
  • Assigned to
    (none)
  • Category
    Compiling/Testing Games

Tags


Attachments

* log-2024-04-05.zip (145.21 kB - downloaded 790 times.)