Bug Issue: Windows compilation fails (Process creation failure : cl.exe)

Pages: 1


  • Level 3 Stencyler
February 06, 2016, 11:33:51 pm

I have a game which compiles correctly in XCode to iOS and Mac desktop.

Trying to move the game to Windows, I have a new install of Windows 7, with Stencyl 8868, and jdk-8u71-windows-x64.  Each time I try to compile the game, I receive a fail message, and the exact same error codes. 

See this thread for more information:  http://community.stencyl.com/index.php/topic,45197.msg257628.html#msg257628

Have tried editing the hxcpp_config, adding an environment variable, installing 'vs_community_ENU' from MS website (not Stencyl), installing VS from Stencyl,,,,,,  and nothing works so far.

This Stencyler is apparently having a similar problem:
« Last Edit: February 07, 2016, 12:50:05 am by Minimo »


  • Level 3 Stencyler
February 07, 2016, 01:55:17 am
Finally found that VS2015 was the culprit.
Uninstalled everything, and installed VS2013 r5.

Seems to be working now!
« Last Edit: February 07, 2016, 01:55:55 am by Minimo »


  • Master Stencyler
  • *
February 07, 2016, 05:01:52 am
Code: [Select]
[haxelib.exe] Process creation failure : cl.exe
is definitely a problem with Visual Studio. What is strange is, that several users reported that installing VS2015 fixed this error for them:

« Last Edit: February 07, 2016, 05:04:49 am by captaincomic »

Issue updated by captaincomic - February 07, 2016, 05:04:49 am
  • Issue renamed from "Windows compilation fails with 8868" to "Windows compilation fails (Process creation failure : cl.exe)"

Issue updated by captaincomic - February 07, 2016, 05:48:16 am
  • Status changed from New to Confirmed


  • Level 3 Stencyler
February 08, 2016, 01:10:51 am
Thank you again Captain.



  • Level 2 Stencyler
February 12, 2016, 03:28:53 pm
I was having the exact same issue, not sure what installed Visual Studio 2015 (Unity maybe?) but suddenly my Stencyl Windows builds would no longer compile. Just uninstalled 2015 and installed 2013 v5 and everything is working again!


  • Master Stencyler
  • *
March 28, 2016, 12:22:14 pm
Here's a possible explanation;
Hi All,

After searching for a solution to this problem today, I discovered that "Visual Studio 2105 Community" no longer includes C++ as part of the install. It only installs for C# and Basic by default. At the start of the install process choose the "Custom Install" option rather than "Default" and tick the "Language C++" check box (It will also select the relevant sub-items for you).  BTW. When you choose the "Custom Install" option it also installs the "Default" options as well.   

After restarting my PC, the Stencyl IDE was able to see it and compile my game for Windows.
PS. I am running  Windows 10 and Intel i7 CPU.

Just another suggestion for anyone having this problem. 

Could someone, for whom VS2015 didn't work, give this a try?
  • Status changed from Confirmed to Need Info
  • Issue Assigned from (none) to captaincomic


  • Master Stencyler
  • *
April 10, 2016, 11:03:42 am
I updated the installation instructions and made it prompt for a VS installation the error appears in the logs.
  • Status changed from Need Info to Resolved


  • Level 2 Stencyler
April 10, 2016, 11:24:43 am
I also fixed this today coincidentally by making sure to install the C++ command line tools on the install > custom menu :)

Issue updated by captaincomic - April 19, 2016, 06:38:35 pm
  • Status changed from Resolved to Closed

Pages: 1


  • Reported
    February 06, 2016, 11:33:51 pm
  • Updated
    April 19, 2016, 06:38:35 pm

  • View Status
  • Type
  • Status
  • Priority
  • Version
    Stencyl 3.4, 3.4.0 beta2
  • Fixed in
  • Assigned to
  • Category
    Compiling/Testing Games