Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Luyren

Pages: 1 ... 147 148 149 150
2221
Probably because of the repeat inside the repeat. (we need to go deeper... ._.) Though I coul be wrong about this.


And you're creating the actors at startx/starty, when I think you should be creating them at x and y (your attributes that are incremented).


2222
Chit-Chat / Re: Where are you from?
« on: April 04, 2011, 04:46:44 am »
Heck, why not?

Brasilia/Brazil. For those of you who don't know, Brasilia is the capital of Brazil.

2223
Shared Resources / Re: Cutscene pack
« on: April 01, 2011, 01:55:01 pm »
I will also modify all existing triggers such that they can be fired without a collision.  There will be a new field on each trigger called something like "Trigger on Step" -- and whenever the scene step value hits that number - the event will be triggered.  This should allow some more creative things by making events happen that aren't near your main moving actors.

I was going to ask about activating without collisions, and you surprise me yet again! This one I'll definitely use for my current project. Looking forwar to it!

2224
Game Art / Re: Strasteo's Static Images
« on: April 01, 2011, 12:02:57 pm »
*whistle*
That's awesome! Gotta admint, I'm a fan of your style!

2225
Shared Resources / Re: Cutscene pack
« on: March 31, 2011, 11:59:05 am »
Would this pan camera include move camera to position over time? I think that's the only "generic" sensor missing. And is the message sensor able to keep constantly firing the message (with time limit or not)?

And slow motion? I didn't expect that! Great job! No doubt this is gonna be the most downloaded pack in the future!

2226
Ask a Question / Re: Jittering Problem
« on: March 31, 2011, 09:48:52 am »
"Test Game" is up on Forge.

2227
Ask a Question / Re: Jittering Problem
« on: March 30, 2011, 07:32:26 pm »
Oh... well, I tought this was an old problem. But what does bother me is:

Quote
I noticed that sometimes, when I stop walking with the hero, the equipments are in a different position every time. This is noticeable with the boots.

I've never noticed that before. So perhaps something is wrong with the position blocks, or the wait the position is calculated?

2228
Ask a Question / Jittering Problem
« on: March 30, 2011, 07:08:17 pm »
In Dungeon Rush!, the hero actor creates all his equipment on the fly, and set the position and animation constantly. But right now, these equipments are jittering when moving, and I noticed that sometimes, when I stop walking with the hero, the equipments are in a different position every time. This is noticeable with the boots.

Here is the test room.

Attached is a screen shot of the behavior for the weapon (if I show the others, it might contain spoilers, but the logic is basically the same).

I can't present the full game with this problems. When the hero is fully equipped, it looks horrible with this jittering. So I need help and ideas on what's causing this.

My tests:
- Tried making the hero always simulate, but it doesn't change a thing;
- Setting scale to x1, didn't do much good;
- Setting the equipment actors to cannot move and cannot be pushed, without success.
- Tried not to set the animation;
- Tried to round the x/y position of the actor, but it didn't change a thing.

Could this be something with StencylWorks? I played the old DungeonDash! demo, and I noticed that it doesn't have this jitter. I'm out of ideas about what's causing this. Specially because this Equip Weapon behavior is the same from the old demo.

b368 (ZIP preview)
Windows 7

2229
Shared Resources / Re: Cutscene pack
« on: March 29, 2011, 06:39:32 pm »
First of all, AWESOME job.

Second, I think the addition of one new sensor would be terrific: Message Sensor.

It would have a list of messages to tell the actor, and a list for wich behavior to tell that message (and an option like add [All] to the list, and the message will be sent to all behaviors). Since I place all the action logic in my behaviors to be performed via messages, this would be perfect.

That way, for tabletop's example of firing a weapon, I'd just have to tell that actor to "Attack", and place the firing logic in a message called "Attack".

2230
Resolved Questions / Re: Weird reaction to "Region has value"
« on: March 27, 2011, 06:40:19 am »
Thank you very much!

2231
Resolved Questions / Weird reaction to "Region has value"
« on: March 26, 2011, 07:27:42 pm »
Another strange bug. At least I think it's a bug. I've build a test game for this, it's called "Test Game", and it's on Forge. A heads up, the bottom most rectangle on the "bug2" screenshot is a terrain region.

The behavior that reproduce this problem is Test Region (attached). I've configured two actors, "asdasd" (the hero from dungeon dash) and "Test" (a random scribble). "asdasd" creates a region and makes the region follow him, but "Test" don't create regions, as you can see in "bug1".

And the problem is seen in "bug2". It's printing both actors name, when only the actor who created the region (and the region attribute has value) should be printing. Besides, it's "Test" who is setting the position of the region, and not "asdasd".

I have no idea how the "Test" actor got the value of the region in the first place!This bug first appeared on Abyss Souls (Keep Falling, for those of you who still remember). A monster that was set to be passive was aggressive, and then I noticed it was using a region (like an aggressive monster), even though it doesn't create one.

Windows 7
b368

2232
Old Bugs (1.x/2.x) / Re: List Game Attributes are empty[?]
« on: March 26, 2011, 06:30:33 am »
D'oh! Sorry, it's up now.

2233
Old Bugs (1.x/2.x) / Re: List Game Attributes are empty[?]
« on: March 26, 2011, 06:06:29 am »
Oh... so the problem is with the < [ ] contains [ ]> block, right?

2234
Old Bugs (1.x/2.x) / List Game Attributes are empty[?]
« on: March 26, 2011, 04:14:55 am »
You can't get an item or check if a GA list contain items, even though you add items to the list and save. You can still print the list and it will show all the items.

Notice the attached image "bug". It's only printing one of the commands. As you can see in "bug2", both the actor's list and the game attribute list have the item "potato". In "bug3" I try to draw the index 0 from the game attribute list (wich should be "potato"), but instead it prints NaN. In "bug4" I try to print the entire list, and now it prints properly "potato".

"Test Game" is on Forge. Check the actor "asdasd" and the behavior "Test Lists".

b368 preview
Windows 7

2235
Chit-Chat / Re: Random Chat Thread
« on: March 23, 2011, 03:29:22 pm »
I must share this with the world!

The E string of my violin broke while I was studying today. I have no reserve E string, and I have violin class tomorrow. The worst part is that a decent set of strings is expensive and, guess what, I don't buy crappy strings. Oh boy. D:

Pages: 1 ... 147 148 149 150