Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - DonPepe

Pages: 1
1
Ask a Question / Reset Time for doAfter Block
« on: October 18, 2011, 05:54:52 am »
Hey,

Is this possible? I have kind of a status on an Actor if he collects an Item. After 5 seconds he gets the idle status back. I do this with a doAfter-Block. Now if he collects a similar item within the 5 seconds the status still gets set to idle after the 5 seconds of the item he collected first, so if I could reset the doAfter block or set the time to a new value this would solve my problem very easily.

Thanks for help,
DonPepe

2
Hey,

I'm still trying to develop a little PacMan clone. In the screenshot you can see the blue PacMan on one of the triggers, where he should be told to change his direction. The Problem is, that I cannot catch when PacMan is in the right place to turn (without running into a wall) because the x of self and the y of self blocks return wrong coordinates for the T-Trigger. The behavior lies on the trigger, "the actor" is PacMan. The coordinates of PacMan are right, checked that. So i can't see why the Coordinates of this Trigger are different from PacMans.

Give it a shot,
DonPepe


Dumb collision groups fail, can be deleted ;)

3
Resolved Questions / [Solved] Sinus & Cosinus Problem
« on: September 26, 2011, 05:27:25 am »
Hey,

I'm doing some kind of a 2D sailing simulation. Right now I try to get the force which the wind pushes in the sail, but I stuck with the use of the Sinus/Cosinus blocks. The attributes Wind and Sail are just the angles of the wind and the sail, set correctly via messaging from other behaviors.

I don't know why, but this function is trying to fool me. As you can see I can print the values and there are strange things happening. The values just jump around as they like. For example the cos for 75° is 0.92 and for 72° I get -0.96 which is obviously wrong.

Can anyone explain that to me?

4
Old Bugs (1.x/2.x) / [Solved] Scene is bugging, no changes can be saved
« on: September 20, 2011, 07:05:27 am »
Hey,

I'm having a bug with a scene which is refusing to adopt any changes I make. Neither adding an actor nor adding a Behavior is working. If I save, close the scenes' tab and open it again the actor/behavior disappeared.
I tried restarting stencyl and my computer, neither of them solved the problem.

There's a picture attached and the .xml file, it will be a PacMan clone, here with dummy-graphics from the forge.
If a can provide further information, let me know.

Best regards,
DonPepe

5
Old Bugs (1.x/2.x) / VisitURL bug, seems to cache the answer
« on: September 01, 2011, 01:59:59 am »
Hey,

I'm developing a quiz for a closed group of players. To keep the score I have set up a database where some information are stored. None of the players should be able to do the quiz twice, so I save the index of the quiz in the database and compare it with the actual index of the quiz (saved in a gameAttribute).

The .php returns the index of the quiz the user played last time. Than on mouse release, there's something like a switch case, where the player gets send to the next scene.

It works perfectly if I close the game and start it again. But when you finished the quiz and after the high score you head for the menu without reloading (there's a Button for that) the game index is loaded wrong from the database. As you see in the screenshot the index gets loaded every time you come to the menu(where this button lies). At this time, the index in the database is correct and if I call the .php-script via my browser it returns the correct index, too. So I wonder why the VisitURL Block still returns the old index(the one it loaded as I started the game, meanwhile it was overwritten in the database).

So it seems to me, like the answer from the .php script is saved and not correctly reloaded like it should.

Besides, am I right that the inner of the VisitUrl block gets processed after the response from the URL was received?

Appreciate help,
DonPepe

6
Ask a Question / Confusion about the VisitURL block
« on: August 31, 2011, 01:20:25 am »
Hey,

I'm developing a quiz for a closed group of players. To keep the score I have set up a database where some information are stored. None of the players should be able to do the quiz twice, so I save the index of the quiz in the database and compare it with the actual index of the quiz (saved in a gameAttribute).

The .php quiz returns the index of the quiz the User played last time. Than on mouse release, there's something like a switch case, where the player gets send to the next scene.

It works perfectly if I close the game and start it again. But when you finished the quiz and after the high score you head for the menu without reloading (there's a Button for that) the game index is loaded wrong from the database. As you see in the screenshot the index gets loaded every time you come to the menu(where this button lies). At this time, the index in the database is correct and if I call the .php-script via my browser it returns the correct index, too. So I wonder why the VisitURL Block still returns the old index(the one it loaded as I started the game, meanwhile it was overwritten in the database).

Besides, am I right that the inner of the VisitUrl block gets processed after the response from the URL was received?

Appreciate help,
DonPepe

7
Archives / Refresh Attributes on Actors
« on: August 19, 2011, 05:39:52 am »
Hey,

Sometimes it's hard to develop a more complex behavior in one rush, so I prefer to do it step by step and test each step for itself. Unfortunately when I add attributes to the behavior the attribute list on the actor won't update, so I have to remove the behavior from the actor and set it again to have the updated attributes.

A button to refresh the attributes directly on the actor would be great.


Best regards,
DonPepe

8
Resolved Questions / [SOLVED] Problem with a flickering picture
« on: August 18, 2011, 04:11:28 am »
Hey,

I'm trying to do something similar to the maze example, where a big black picture with a hole in the middle is placed over the player to simulate light.
The only difference I see is, that my picture is a bit bigger, because my game has a resolution of 640*480 px, so my LightPicture has to be 1280*960 px big. The format is standard .png that comes out of photoshop

The issue I experience is that when the player is near to any border of the screen, the edges on the other side begin to flicker weirdly. I added a screenshot but they really flicker around.

Anyone a good advice to avoid that?

Best regards,
DonPepe


[SOLVED] it by myself, just hat to lock rotation for the light-actor.

9
Ask a Question / Database access via PHP
« on: August 16, 2011, 04:41:40 am »
Hey Folks,

I am trying to get an Highscore on my own MySQL database. Unfortunately I'm not that fit in PHP and I can't figure out what my fault is. I'm stuck with adding a new player to the database.

I got the PHP code from a tutorial and changed it a bit. When I call the file via browser with a hardcoded $PlayerName it inserts the player correctly to the database. But via my Highscore-Script nothing happens, so obviously my problem lies inbetween the connection.

I played around with these two blocks, but nothing happens :/

Appreciate for help,
DonPepe


PHP:
Code: [Select]
<?
##The registration script adds a record to the SQL database with the user's Name. That's about it.

###This first line of Code is to load your database variables.
include ('Include.inc');

##This line takes out everything from the $Name variable that is not a captital or lowercase letter or a interger between 0 and 9.  This line is only for security purposes so that users can not enter anything that could disrupt the database. You can take this line out if you want.  Or you can allow users to enter other symbols by including a \ followed by that character right after.
$PlayerName = ereg_replace("[^A-Za-z0-9 ]", "", $PlayerName);

#Connects to the Database.
$Connect = mysql_connect($DBhost, $DBuser, $DBpass);
@mysql_select_db("$DBName");

#Preforms the SQL query
#$query = "INSERT INTO $table (id, name, score) VALUES ('' , '$PlayerName', '')";
$sql = 'INSERT INTO `db10454523-quiztime`.`highscore` (`id`, `name`, `score`) VALUES ('', '$PlayerName', '');';
$result = mysql_query($query);

#Gets the number of rows affected by the query as a check.
$numR = mysql_affected_rows($Connect);

if ($numR == 0) {
    print "Status=Failure Please Fill out all Fields - Register Again";
}
else if ($numR == 1) {
    print "Status=Success You can Now Login - Login";
}

else { print "Status=General Error - UserName already in Use";
}

?>

10
Ask a Question / How to include custom libraries
« on: August 12, 2011, 02:28:33 am »
Hey,

as I read there will be code-blocks for mochimedia stuff I wanted to try to get my game ready for it (cause I want to use their highscore-api) but I can't figure out where to place the .as3 files from mochi so I can import them anywhere in stencyl.
Finally the question, how can I include third-party actionscript files?

Best regards,
DonPepe

11
Ask a Question / Proxy Problem with missing blocks
« on: August 09, 2011, 02:26:27 am »
Hey,

I'm trying to get through my companys proxy with stencyl.

I did all the stuff here http://community.stencyl.com/index.php/topic,1095.msg10040.html#msg10040 and I can connect to the StencylForge, but as an other result I have much codeblocks missing.

Somewhere I read in this case i have to "Reupgrade StencylWorks" to solve this, but when I try there's again no connection.

Best regard,
DonPepe

12
Archives / Delete Code Block by Middle Mouse Button
« on: August 09, 2011, 12:32:13 am »
Well, as I'm new to stencyl i often grab the wrong code block in the design mode. So for me, and I guess for others too, it would be great if i could delete blocks faster than with rightclick->remove or with strg+k.

The MMB would really improve the, at least my, workflow.

Best Regards,
DonPepe

13
Ask a Question / Pixelcap for Actors?
« on: August 04, 2011, 04:29:47 am »
Hey,

I'm trying to do an intro for my game with some curtains hanging in the screen and stuff. As they should move around they must be actors, right?
But I can't place them on the screen and wondered why. They are up to 640x480 px large (as my screen is) .png pictures with transparency.
What's my fault?

Best regards,
DonPepe

14
Ask a Question / Getting which key was pressed
« on: August 02, 2011, 05:28:57 am »
Hey,

I'm planning to develop a little learning game. However the user has to write a word that is shown on the screen.

I want to check letter by letter if the user typed in the correct word. So I want to build an if-statement if any key is pressed, and in that if-statement I want to give that pressed letter to an attribute that is declared for the behavior.

The Problem is, I can't find any code-snippet which is getting a "random" pressed key, just one for the keys you define as Jump-Key etc.... And I don't know how to implement event listeners in Stencyl as I would use it in "normal" Flash.

Would be gratefull for some help, or even a workaround.
Best Regards,
DonPepe

15
Old Bugs (1.x/2.x) / Little bug when creating an account
« on: July 07, 2011, 01:53:37 pm »
Hey,

I just created an account in StencylWorks and i couldn't use my main mail adress because it's a "-" in it.

Best Regards,
Jan

Pages: 1