Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - molegato

Pages: 1
1
Resolved Questions / Re: java.io.FileNotFoundException
« on: May 15, 2014, 03:13:08 pm »
Great, now I feel like a stupid... I duplicated an event by mistake and it appears I forgot to delete it afterwards.
But a million thanks!
This thread can be closed now, and I guess if someone ever falls in the same pit I did, this thread will appear on his search.

2
Resolved Questions / Re: java.io.FileNotFoundException
« on: May 15, 2014, 02:46:35 pm »
I have attached the logs to the original post.

3
Resolved Questions / java.io.FileNotFoundException
« on: May 15, 2014, 06:48:42 am »
Hello. Recently my game stopped working althogether, stencyl just couln't export or test it.
If I try the flash file test, I get a white screen. If I try the browser flash test, I get the following error message:
Code: [Select]
[LOG] Running inside browser.
[ERR] java.io.FileNotFoundException: C:\Users\Raul\AppData\Roaming\Stencyl\stencylworks\games-generated\Fureedom fighters\Export\flash\bin\Fureedom fighters.swf (El sistema no puede encontrar el archivo especificado)

I have seen this has happened to some other people, but they didn't get any helpful answer. Please, if you know something about this, share the info.

Edit: logs attached

4
Ask a Question / Stencyl 3.0, x3 scale mode?
« on: May 04, 2014, 11:38:54 am »
Hello! I've ported my game from stencyl 2 to stencyl 3. It is a retro/pixel game, so I was using the x3 zoom.
This option is missing now, as I can only select 1x, 2x and 4x. That makes some sense, but 2x and 4x really don't work quite well for my game. Is there any workaround to get 3x scale mode back? Is there any option to set the scale mode to automatically fit the window/frame size?

5
Ask a Question / Moving platform
« on: April 24, 2014, 03:45:49 am »
Hello, I made a moving platform behavior but ran into an issue. Setting the physics settings to 'cannot be pushed' makes impossible for the event to recognize collisions and act accordingly. I need it to turn when it hits certain actor, so right now I have to choose between a pushable platform (bad) or one that goes on and on forever (worse).
Is there any handy workaround?

6
Ask a Question / Re: Group - Group collision event
« on: April 20, 2014, 09:34:05 am »
It's ok, don't worry. I feel a bit uneasy sharing the project when it's halfway trhu production ( I know you won't steal it, but I can't help it).
And yeah, you can use the 'Tiles' group on actors without problem, and that's great for blocks like in mario games, special platforms and so on.

7
Ask a Question / Re: Group - Group collision event
« on: April 20, 2014, 08:20:36 am »
xD well thanks for the involvement, but yeah, physics are normal and the tiles are impassable (full square collision)
I'll run some tests to check if it's the whole event that's broken, or just my groups. I'll edit this when I see what's happening.

Ok, found the exact problem. The event triggers if I place an actor of the 'Tiles' group, but not with actual tiles. Might this be a bug?
As a workaround I'll have to place invisible actors where this check should be performed, I guess...

8
Ask a Question / Re: Group - Group collision event
« on: April 20, 2014, 08:02:59 am »
Well, sorry for not explaining that. But the 'flying' collision box has to touch 'cieling', while the ground one keeps the character overground. I want to check wether or not the character can get up or there are blocks over him. So the tall collision box actually overlays the tiles, but the event doesn't trigger.

9
Ask a Question / Re: Group - Group collision event
« on: April 20, 2014, 07:45:52 am »
Of course! I've added the event, the actor collision settings and the group collision settings in the same image.
I guess the mistake has to be in one of those places! ^^U

10
Ask a Question / Group - Group collision event
« on: April 20, 2014, 05:46:34 am »
Hello. I've been trying to check if ANYTHING from a group is hitting anything from another. Specifically, the second group is tiles, and the actor of the first one has the collision to sensor. I know they're colliding, as it's registered if I use the actor-group collision block. However I need to use the group - group, which doesn't trigger under any circumstance.
The blocks in the event are as simple as a 'print: eh', that doesn't show. Has anyone run into that bug? Is there any particularly tricky catch about that event that I'm not aware of?

Thank you so much for your time.

Edit: added a screenshot of the event, the actor collision settings and the group collision settings.

11
Ask a Question / Re: Stencyl 3.0 and escape characters
« on: April 16, 2014, 06:34:27 am »
Thanks! I was thinking about doing that if there wasn't an option. But why \\n, if escape characters are already ignored?

Edit: Tried it, and I got it. It's the game that ignores the escape characters, not the editor.
Many thanks again!

12
Ask a Question / Stencyl 3.0 and escape characters
« on: April 16, 2014, 04:23:03 am »
Hello. I recently moved my project from stencyl 2.2 to stencyl 3.0, and ran into a problem.
Before, inserting '\n' inside a string made the 'draw text' block to draw a multiline string. Now it just draws '\n'.
Did stencyl 3.0 remove the escape characters? If so, what's your workaround?

13
News / Re: Legacy Releases (1.x / 2.x)
« on: April 15, 2014, 03:05:03 am »
Hello. The 3.0 update made my current project incredibly buggy, so I decided to download the old 2.2 version. However, the download goes really slow, and about halfway trhu, it 'completes', leaving me a corrupt installer that doesn't work. Does that happen to anyone else?

14
Ask a Question / Re: Custom blocks: scene attribute returns number?
« on: April 06, 2014, 05:53:38 am »
Thanks! While I knew about that block, I hoped that I could use the scene attribute for convenience's sake. I take that this behavior is bugged, then. Just out of curiosity, ┬┐is there any bug->workaround compilation somewhere in this forum?

15
Ask a Question / Custom blocks: scene attribute returns number?
« on: April 06, 2014, 04:58:09 am »
Hello. I'm trying to make a custom block that uses a scene attribute, inside of said block I load that scene.
The problem comes when executing the game, I get an error 1034 (type conversion error) saying that '0' or '1' cannot be converted to Scene. Is this the normal behavior of scene type attributes? If so, how can I reference a scene by it's associated number?

Pages: 1