Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Zeanon

Pages: 1 2
1
Ask a Question / Re: Mobile Keyboard not drawing text [Help]
« on: September 09, 2015, 04:24:05 am »
Sorry for the long delay, i was into some family matters and everything got settled back.
The extention seems to be working fine. I don't know if others have found any bugs but for what i wanted to do with it it seems to be working just fine. Cant wait to see it fully implemented.

2
Ask a Question / Re: Mobile Keyboard not drawing text [Help]
« on: July 16, 2015, 10:11:28 am »
Thanks a lot! i will test it in the following days!!!
I will reply with confirmation of how well it is working! Glad to see that we are going to have such an option!

3
No not yet as it seems.. Still i wanted to leave the question open for a while to see if other people have the same problem, just to be sure it is a bug and not something i might be doing wrong. As it is i think its a bug but i saw only two or three people talking about it other than me.

4
Thanks even if you couldn't do anything i am happy that at least someone tried to discuss the matter with me..
As you said i think so too that it is a bug within Stencyl. Lets hope it does get fixed,  :)

5
Sure..
Listen in the Groups i have set my actor(the player) to collide with both tiles and cliffs and of course i set both cliffs and tiles to collide with the actor. As i said before it seems that somehow it registers the collision shape the same as its parent actor group rather than the different group i assigned it to.
The same problem was found and in an other post..
http://community.stencyl.com/index.php/topic,36171.0.html
Just for reference

6
Ask a Question / Re: Multiple Collisions on one Actor?
« on: February 20, 2015, 08:19:12 am »
I seem to have the exact same problem...    :'(
Did someone find  a way to fix this?

7
Basically what happens is that i cant seem to get a collision shape to register as a collision in the group for which I set it. It keeps registering as the actor's collision group.     

Is this a bug?

8
No i did set my player to collide with both groups Tiles and Cliffs. So no this is not the problem.
What happens is that when i test the scene the road actor is set only to the parent group collision type and does not include the other collision shape i set as a cliff group.
Thanks for trying though  :)

9
Hello fellow stencylers again! :D
Ok, so i have a road actor with a cliff like thingy.
What i want to do is to set that when the player is on the road it is ok to jump but when it is on the cliff you cannot jump (so it can kill it self by diving into the cliff and out of screen).
The collision code for the player works just fine and he jumps when on road, but then i added the code for it to detect the collision when the character is on (or over) the cliff and although it should work just fine, it doesn't.
What i found out is that in the collision shapes i made for the actor although the two sides were defined as Tiles and the shape for the cliff is selected as a different group called cliffs the cliff group is not detected when i test the scene  because in the properties the actor is selected as a group of tiles. The exact opposite happens again when i select from the properties the group of the actor as a group of cliffs and the effect in the test game is not letting the player jump. What i understand is that although in the collision properties i am able to assign different shapes for different groups in the same actor somehow they don't work except only for the type of the parent group .
 
Sorry for the long post but i don't know how else i should describe the problem with less words.
Thanks for any advise in advance   :)

10
Resolved Questions / Re: Problem with the nme.Lib.exit () ; code
« on: November 19, 2014, 05:07:40 pm »
You were right!
That did work better! Actually it works like a charm!!!
I will post some screenshots of the code so that others with the same problem will be helped  ;D

Thank you very much your suggestion was on the mark!

Edit: System.exit(1);    (for the screenshot)

11
Ask a Question / Re: Is making othello hard?
« on: November 19, 2014, 04:08:13 pm »
Well you can make pretty much anything in 2D with Stencyl as far as i am concerned. Now making an Othello game is possible of course, the only factor can think right now that may be hard, is for you to get a suitable scale of the board.
The logic for an A.I could get complicated if you want a really really good A.I, but you can always keep things simple with only a few moves for the A.I to choose from.
I think Stencyl can help you do what you are searching for but it will require some effort.
As for how long it could take you, i should say, it depends on how complicated you want your game to be and how fast you can learn to use Stencyl.
I wish you good luck on your project!

12
Resolved Questions / Problem with the nme.Lib.exit () ; code [Solved]
« on: November 19, 2014, 03:49:06 pm »
Hello friend Stencylers!
I used the above code with the overide back button so that i could exit the game properly from the main menu.
The problem is that when someone tries to access the game from the recent apps section of the android the game is shown as a black window instead of showing the last scene (the main menu in this instance).
Any thoughts of what i can do ?
I attach the sceenshots to the code as well of the black screen in the recent apps so that you can understand better what i am talking about.
Many thanks beforehand!

13
Ask a Question / Change between atlases produces lags? [HELP]
« on: November 16, 2014, 07:48:58 pm »
So i figured i should do some optimizing to my game by using the atlases in order to relief heavy use in memory.
So i set the credits/opening scene to the main atlas and then i distributed everything else evenly, atlas per scene. What i found out was that one scene (not the initial one) was lagging when it was changing to another scene and thus atlas.When i set all the scenes to a same atlas,(atlas 2) except the opening scene, the lag was gone away but now the credits scene which is in the main atlas seem to be the one lagging a little bit before changing scene to get to the main menu.
Keep in mind that when everything is on one atlas everything works flawlessly without any lag... well except a probability of the app crashing on start up he he  ;)   
Any thoughts on some workaround about the lag? or maybe i am doing something wrong?
Many thanks beforehand.

14
Ask a Question / Re: Mobile Keyboard not drawing text [Help]
« on: October 31, 2014, 03:46:31 am »
Sdieters i tried downloading your package through StencylForge and i cant, it sends an error that maybe the resource was not fully loaded to their servers.
I thought you should know it...

15
Ask a Question / Re: Mobile Keyboard not drawing text [Help]
« on: October 31, 2014, 03:05:48 am »
First of all thanks for the help..  :)
Sdieters i like your virtual keyboard, i will certainly use it as it seems.. Does it work for Ios too ?
To Innes, unfortunately as you already feared i am not able to access the thread, so could you please ask how things are going with this?

Thanks to both of you, i am leaving the post open for a while more so we don't need to start a new topic, even though my question seems to be answered to one point.
 

Pages: 1 2