Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Caligari

Pages: 1 2
1
If I switch to Stencyl's haxe and list the library versions I see:
Code: [Select]
actuate: [1.6.5] 1.7.2
air3: [0.0.1] 3.4
box2d-fake: [1.11]
box2d: [1.11] 1.2.0
console: [1.00]
format: [3.0.5] 3.1.2
haxelib_client: [3.1.0-rc.4]
hxcpp: [hxcpp]
layout: [1.1.0]
lime: [lime]
openfl: [openfl]
polygonal-ds: [1.4.1]
polygonal-printf: [1.0.0-beta]
stencyl: [1.00]
svg: [1.0.8]
swf: [1.7.4]
tilelayer: [0.2.1]
tjson: [1.2.3]

Which of these are used by Stencyl, and are any of the versions wrong? Air3 and format are the ones I'm concerned about.

2
OK!

For me that has fixed it.
Code: [Select]
haxelib setup "C:\Program Files (x86)\Stencyl\plaf\haxe\lib"
haxelib set actuate 1.6.5
haxelib setup "C:\HaxeToolkit\haxe\lib"

Is there a list I should have found that lists the expected versions of all of the libraries which Stencyl uses?

3
Any other suggestions?

4
That certainly seemed to fix the Box2D issues, but still no dice.

5
Just checked that a Clean didn't fix things, somehow. It doesn't.

6
Uninstalled.

Checked that entire install directory was indeed gone.

Downloaded 3.3 from website, to be certain.

Installed.

Checked that directory tree is there and plaf hax libs include only 1,11 Box2D version.

Run Stencyl; open same project; test; same result (flash player with no game; nothing in games-generated bin for flash).

I thought it would work (and fail after I rebooted next)...

7
I've installed nothing to Stencyl's areas past its install. When I did the last uninstall and reinstall I made sure the whole directory was gone, to be sure nothing was left behind in the install area (not the stencylworks data area where my games are).

I haven't even had occasion to install a physics library at all for my own work (outside of Stencyl).

8
Unfortunately that didn't change the result - nothing runs, and nothing is generated.

Here's the new log for that, although I'm not sure there is much in the way of new information in it. Hmmm.

9
I have been having a lot of trouble with my Windows install of Stencyl (3.3).

Firstly, I'm a haxe developer, usually using OpenFL with various libraries and frameworks. This has definitely been a problem in the past, and I gave up running Stencyl on my Windows PC because it either didn't run, or it interfered with the development I was doing. This was because Stencyl has its own copy of haxe and libraries, and they are rarely at the same versions as the ones I'm using.

This may be the problem I'm having now, as well. Is Stencyl compatible with having a haxe install on the same PC (Windows)?


Specifically, what I believe I'm seeing when I try to test or run a game, is that it saves, compiles, finishes, and then brings up the flash player which is blank and not the size of the game I was testing. Looking into it a bit, I have been unable to locate any output in the bin directory; if I go into games-generated for a game, into the Export directory, flash, and then bin, there is nothing there. I'm assuming from poking around that this is where the flash file should be.

Similarly, if I try to test in Windows native, looking in its bin directory I have the lime.ndll, a manifest, regexp.dll, std.dll, and zlib.dll, but no exe at all.

I was able to get things working a week ago, when I uninstalled Stencyl and reinstalled it. For that session everything seemed to work as I expected, and I assumed it was all working. But since that time it hasn't worked again.

I noticed, today, that when I tried running haxelib list from the command line it gave me a message I recognize as happening when haxelib is pointed to Stencyl's libraries. I reset my haxelib path to my own install and was able to upgrade my libraries. Running Stencyl and trying to compile returns haxelib to its confused state. But it doesn't seem to matter whether it thinks it is pointing to the Stencyl hax libraries or mine, it is always unable to create binaries.

I assume I could reinstall it and get it to work, but I really don't want to have to uninstall and reinstall it every time I want to use it.

Any advice would be very welcome. I'm willing to poke at things for more info, if needed. I've included the logs from my attempts today.

10
Just wondering if there are any recommendations when taking a Stencyl 3.1 project with the Dialog Extension and updating to the new version of Stencyl and the extension.

It seems that the dialog text is not stored in the same place. I've manually opened the old file and moved them across, but I'm not certain what settings and such I will have to locate and reset as well.

Advice?

Thanks!

11
Ask a Question / Re: What remains to be done for Ouya support?
« on: September 21, 2014, 10:28:27 pm »
Its a shame, as they are so easy to get a hold of second hand at the moment. Ah well!

12
Ask a Question / Re: What remains to be done for Ouya support?
« on: September 21, 2014, 08:47:37 pm »
No info?

I think Ouya would be an excellent target for learning. I know the kids I've worked with would be really excited to be able to make an Ouya game, and ultimately make it available on the official store.

13
Ask a Question / What remains to be done for Ouya support?
« on: September 15, 2014, 09:49:41 pm »
I'm curious about what remains to be done in order to make the Ouya a first-class publication target? Is it stuff on the OpenFL side, or the Stencyl side?

14
Dialog Extension / [SGST] Notes for initial use
« on: August 03, 2014, 11:19:11 pm »
Just started using the the Dialog Extension, and noted a few things along the way:

* I was convinced it wasn't working for the longest time, because the initial default window definition was below the height of my window.

* Once I could see the window I wasn't able to advance the dialog at all, because the interface controls were not present and defined.

* I think it would pay to have some lines to address these in the Intro notes somewhere, notably that you should be aware that the default window assumes a 640x480 application size, and that you must define "v" and "action2" controls, or override those settings, in order for the dialogs to work.

* After that, I was thinking you might want to go to the extra trouble to support -ve coordinates for the windows, which would set values based on an amount back from the far side (so an x of -100 would be set to (width-100), and a y of -20 would be set to (height - 20)). A similar system could be used to set heights and widths, with -100 being equal to "100 less than the remaining distance", for example. I've found that it is asking for complications when UI elements, in particular, cannot be positioned relative to the screen edges rather than absolutely.


I should add that the extension is extremely useful, despite these niggles! Excellent work! Thanks!

15
Bug Archives / Re: Windows install with Standard user does not work
« on: August 03, 2014, 08:51:41 am »
I can't see why you couldn't change the prefs, but the directory tree won't be in your user area, and I don't think you can copy it (or even see it) from another user's area, so I don' t think you will be able to run.

Pages: 1 2