Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - FUNWISP

Pages: 1 2 3
1
Ask a Question / Re: Sound / Channels ?
« on: February 07, 2012, 12:57:51 am »
Hey, rob1221

That's interesting to hear, I may experiment with channels other than 1 or 2, I've not been able to get anything working using any channels so far, no volume control, no fade in / out, etc.

Would still be nice to hear officially if this is borked or not, and we're not just wasting our time. :/

2
Ask a Question / Re: Sound / Channels ?
« on: February 05, 2012, 07:53:17 pm »
Nope, nobody.... ?

Any official word on this ?

3
Ask a Question / Re: Sound / Channels ?
« on: February 02, 2012, 12:52:32 pm »
Ok, I'm coming back to tackle this again, and having no luck with it...

Does the channel stuff actually work as it is supposed to, I'm not convinced ... ?

I am trying to play music on channel 1, and some sound effects on channel 2

I set the volume for channel 1 all the way down to 10% ( for test purposes ) and channel 2 to 100 %, this effects nothing, both play at 100% volume on their respective channels, if I ignore the channel stuff, and just set the standard volume ( no channels, just globally ) then the volume works, but obviously effects everything including the sound effects.

Does anyone else have similar problems, or have you got round it, and if so, how did you do it ?

I don't wish to point any fingers of blame, but it seems like the channel stuff just doesn't work correctly ( or possibly my lack of knowledge of stencyl still ) ?

4
News / Re: iStencyl Game Jam Results
« on: January 31, 2012, 06:37:58 am »
Hey, Aasimar

Congratulations on the win ! :)

I took, WH3XLHYNMEMP.  Although it never gets as far as as the playing screen, keeps crashing for some reason, I'm on iPod Touch 4G, latest iOS. :/

5
News / Re: StencylWorks 1.4.1 (Released on Jan. 22)
« on: January 23, 2012, 03:51:16 am »
Seems to be working fine now, Jon ! :)

At least on simulator anyway, can't confirm device.  anyone else ?  I'm sure it's fine. :)

6
News / Re: StencylWorks 1.4 (Released on Jan. 22)
« on: January 22, 2012, 11:37:35 pm »
No worries, Jon, happens to the best of us. :)

Looking forward to the updated version ! :)

7
News / Re: StencylWorks 1.4 (Released on Jan. 22)
« on: January 22, 2012, 10:18:06 pm »
Hi, I'm getting similar similar errors, unable to test on simulator - MAC Address is still correct, so don't understand why ?

8
Ask a Question / Re: Background Music / Sound Effects Best Practices ?
« on: January 20, 2012, 08:43:43 am »
Well, thanks, Alexin

I will keep working on it, hate stabbing in the dark, though. :/

Cheers

9
Ask a Question / Re: Background Music / Sound Effects Best Practices ?
« on: January 20, 2012, 03:29:10 am »
Ok, let me put it another way, I want to play my music at 75% volume, and my sound effects at 100%, best ways ?

10
Ask a Question / Re: Background Music / Sound Effects Best Practices ?
« on: January 20, 2012, 12:37:27 am »
Anybody.. ? :/

11
Ask a Question / Background Music / Sound Effects Best Practices ?
« on: January 19, 2012, 08:35:11 am »
Hi,

I have my game framework in place, and I am currently adding sound effects and music.

Title Screen - Has a scene behaviour which consists of

When Created
-Stop All Sounds
-Set Volume To 50 % For Channel 2
-Loop 'Title_Music' On Channel 2


I have three buttons on my title screen, play, scores and help, within each button for scores and help I have the following snippet of code added to behaviours of the following buttons, Scores, Help and a Back Button : -

Always
other code here, check for 'touched' then
-Stop Sound On Channel 1
-Play 'Button_Sound' On Channel 1

other code here, switch to chosen button scene...


Upon testing scene, the main title screen appears, and music plays and loops, but volume is not affected in any way, it is 100%, setting it to 5% makes no difference on the volume, why ?

I click on a button on the title screen, this plays the sound effect and performs the desired action, i.e. I fade to another scene, where I can hit the back button ( sound effect plays as required ), then I return to the title screen where the music starts from scratch again.

So, based on the code logic above, and for the more experienced users out there, why is the volume being ignored for channel 2 ?  And am I utilising the channels correctly ?

Thanks

12
Ah, good tip, coleislazy, thanks for that !

Hope this is going to be fixed though in future updates.

Cheers.

13
Hi,

In my game, I have an actor ( which is a set of clouds that fit the width of the screen - 320 pixels ( or 640 pixels for retina ) - I am unable to place it for some reason, I can drag and move it around the screen, but it will not drop, I have tried again and again to perfectly line it up to see if that makes any difference within the screen space, but alas, nothing ?

Is there an alternative way to place it ?  Or is this a known bug ?  I can knock 2 pixels off each side - so my actor is 638 instead of 640 and I am able to place it, but I don't want to do that, as the clouds form the backdrop, so it would look silly that 2 pixels are missing on each side.

Thanks in advance.

14
Archives / Re: Add a Glossary of Terms
« on: January 15, 2012, 10:48:02 am »
Looks Good, Jon

Handy resource, which I'm sure will be enhanced further when you add the images.

Regards.

15
Ask a Question / Re: Sound / Channels ?
« on: January 09, 2012, 11:58:09 am »
Ok, thanks Jon, looking forward to reading that documentation. :)

I'm sure they're useful, so would be nice to see how to best utilise them.

Abigayl, thanks, so if I'm not doing anything too intensive, I can get by on just playing some bg music, and sound effects as and when I need them, rather than assigning them to seperate channels ?  I'll go with this option in the interim, until it becomes a problem ! :)

Regards

Pages: 1 2 3