Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Mimicwing

Pages: 1
1
Ask a Question / Re: How can I get my graphics nice and crisp?
« on: October 29, 2015, 12:05:07 am »
Great advice, thanks guys. I'll give that all a go and report back - cheers!

2
Ask a Question / Re: How can I get my graphics nice and crisp?
« on: October 28, 2015, 04:06:45 am »
They're 128x128 in size and imported at 4x, unless that's too small?

3
Ask a Question / How can I get my graphics nice and crisp?
« on: October 27, 2015, 05:30:36 am »
Hey all,

I've created assets for my game in Adobe Illustrator, and saved them as PNGs. The original files look fine, but in Stencyl they look a bit fuzzy and some of the shapes have a thin black outline, almost like a shadow. The curved corners of the squares, and the circles, in particular look bad.

Any ideas how I might tidy this up? Different file format perhaps? Or is there a setting in Stencyl I should try?

Cheers!

ps. I noticed someone else had a similar issue earlier this year that wasn't resolved: http://community.stencyl.com/index.php?topic=38079.0

4
Old Bugs (1.x/2.x) / Re: Can't make a SWF file
« on: September 21, 2011, 07:55:18 am »
This is the problem I'm having. I just got Audacity, and checked myself: both the original file, and the copy made in the resource file are 44.1kH (Opened them both, bottom left hand corner, already says 44100 - i'd already checked them with VLC as well, and the friend who made the music for me says he definitely did them as 44100 MP3s. Which they are.)

However, when I try to export, it's saying that it's 32000Hz (as seen in the screenshot I posted) - and then subsequently doesnt export the flash file.

I'm going to try with a different file, and see if the same problem occurs.

Update: Made a blank game file, and tried each of the 4 pieces of music my friend sent me. They are all showing as 44100 MP3s. However one of them doesnt work. The other three are fine. Now we've pinpointed that, he's looking into if he did anything differently, and one we have some answers I'll post them here and hopefully others can avoid the same problem!

Upadate 2: Ok. So. Basically. Changed the filename. Now it works. I don't even... well I guess my issue is solved anyway. Thanks for the help peeps.

5
Old Bugs (1.x/2.x) / Re: Can't make a SWF file
« on: September 21, 2011, 04:12:06 am »
Actually, just a little note on this. Have checked that both my original MP3 and the MP3 that is copied into the resource folder are both 44.1kHz.

However, I've noticed (when running that command prompt) that it states that the sampling rate is unsupported, at 32000Hz. So that's changing... somewhere. :/

No idea what's going on here. Any ideas?

6
Old Bugs (1.x/2.x) / Re: Can't make a SWF file
« on: September 20, 2011, 05:08:12 pm »
So I had the same error, I tried the java -Xms64m -Xmx1024(m) -jar sw.jar thing. Still didnt work. The only way I could get it to export properly was to remove all the music from my game.

I did notice, that inside the command prompt it says at the end: "[LOG] Unable to transcode ../game/resources/131.mp3"

So I guess something's going wrong there with the music file. Any ideas? I'd rather like to have music in my game :/

7
Old Bugs (1.x/2.x) / Inconsistent Sensor-Collision Error
« on: September 07, 2011, 03:34:51 pm »
I'm using actors with 'is a sensor' enabled in their collision to create buttons that the player can move passed. That is, to register the player moving passed, but not actually blocking the player as a wall might do.

It seemed to be working fine, but for some reason in some scenes the player can 'walk through' the actor as I'd expect, but in others the player collides as if 'is a sensor' wasn't enabled. The actor is the same in all scenes, however.

Is anyone else getting this issue?/Have I misinterpreted what 'is a sensor' does in some way?

Pages: 1